AcuRite Atlas™ (7-in-1) Reset

Follow

If your AcuRite Atlas™ (7-in-1) High Definition Display is showing no outdoor temperature reading, dashes, or the outdoor temperature reading is not changing, please perform the troubleshooting steps below. The reset below can be used if the outside temperature data is missing, blank, showing dashes, or stuck on the same reading for an extended period of time. 

If your AcuRite Atlas™ (7-in-1) High Definition Display is unable to locate your AcuRite Atlas™ (7-in-1) Sensor and is displaying the "No Sensor Found" error, when attempting to add a sensor to the display, these steps may also be helpful.

 

You would want to ensure the following first:

  1. Verify that you are using a fresh set of batteries. The battery expiration date should be at least 6 years out. Batteries can lose 3% of their power or more every year in storage. 
  2. Relocate the display unit and/or the AcuRite Atlas™ (7-in-1) sensor. Under optimal conditions, the units can be located up to 330 ft (100 m) of each other.
  3. Units should be placed at least 3 feet (.9 m) away from electronics that may interfere with wireless communication (such as TVs, microwaves, computers, etc).

 biulding_material.PNG

 

Hard Reset:

Please follow the steps carefully as the order is crucial to the success of the reset.

  1. Bring both the sensor and display unit indoors and position them side by side.
  2. Remove the batteries from the sensor and change the sensor to a new ABC channel. 
  3. Go to the main menu by tapping the "MENU" button.  The "MENU" button is the three white horizontal lines in the upper left-hand corner of the display.
  4. Tap the "Sensor" option from the menu. 
  5. Tap "Remove A Sensor". If the display shows you a picture of the AcuRite Atlas (7-in-1) sensor, Tap "Done" (If the screen does not change/the remove a sensor button does not work, skip down to step 8). 
  6. It will ask you to confirm removing the sensor, tap "Yes".
  7. It will ask you "Are you sure?", tap "Yes".
  8. The display will revert back to the previous screen. Tap the back arrow in the upper left-hand corner of the display to return to the main menu.  
  9. Tap "Factory Reset".
  10. You will receive a prompt asking if you want to reset to factory settings. Tap "Yes".
  11. It will ask you "Are you sure?", Tap "Yes". The display will reset itself and go to the main AcuRite logo screen. 
  12. You will now be able to set up the display by following the on-screen prompts. 
  13. Once that is completed, put the batteries back into the sensor directly. (Follow these troubleshooting steps without the use of a battery pack and/or power adapter.)
  14. Go to the main menu by tapping the "MENU" button.  The "MENU" button is the three white horizontal lines in the upper left-hand corner of the display.
  15. Tap the "Sensor" option from the menu.
  16. Tap "Add A Sensor".  
  17. The display will look for your sensor and show a picture of it when it is found asking if you would like to add it. Ensure that the designation in the description matches the channel that you set your sensor on.  Tap "Add This Sensor".
  18. The display will revert to the previous screen.  Tap the back arrow in the upper left-hand corner of the display twice to return to the main screen. 
  19. Let both sensor and display sit side by side to establish a connection. (Leaving the units side-by-side for 30 minutes will allow you to verify accuracy by comparing the indoor and outdoor readings shown on the display.)
  20. After a connection has been established, the sensor can be placed outdoors. 

 

If you are still experiencing concerns, please contact our U.S. based support staff by Submitting a Request or by chatting with our Live Agents. If you already have an open ticket with a support agent, please reply to the last email sent. 

Was this article helpful?
6 out of 48 found this helpful