My readings are not being sent to Weather Underground (AcuRite Access)

Follow

This may occur when the Weather Underground Station ID or Station Key/ Password entered into your My AcuRite Weather Underground Sharing Profile is not correct. If your readings are available in My AcuRite, please try to resolve this issue by completing the Possible Solutions listed below.

Possible Solutions

  1. Verify that MyAcuRite has been receiving readings for at least 1 hour - your sensor readings are displayed on the Dashboard.

  2. Verify your Weather Underground Sharing Profile in My AcuRite has the correct Weather Station ID and Station Key (Password) and the correct sensor is selected.

    Note

    Be sure to enter the Station ID exactly as it's displayed in your Weather Underground account - in all capital letters and is almost always comprised of eight letters and one to three numbers. If you have an "O" or "I" as the last letter before the number(s), it's very easy to mistake it as a number.

    We recommended not to copy and paste your Password (Station Key). The Weather Underground Station Key is case sensitive and does not allow special characters. The password for your weather station is no longer the same as the password for your wunderground.com account. It is now a separate key (Station Key) that is generated specifically for each Weather Underground station ID.

  3. If your profile is set up correctly, remove and re-enter your Weather Underground profile in My AcuRite. Please wait up to 1 hour for your reading data to be available in WU.

  4. If the reading data is still not available, verify Weather Underground is receiving My AcuRite data updates by changing the location address of the AcuRite Access. The change initiates a connection from My AcuRite to WU. Go to Settings > Devices > Select the AcuRite Access shared with WU > Make a change to the address. Wait for approximately 10 minutes and verify the address change was received by WU.

 
 
Was this article helpful?
0 out of 1 found this helpful