windows 10 anniversary

  • 1
  • Problem
  • Updated 2 years ago
I upgraded to Windows 10 Anniversary Update and since that the aculink program won't run.  I have uninstalled and reinstalled and it still doesn't work.  The program seems to install fine, but when running it you just get the spinning wheel for a moment and then nothing appears.  I've tried run as Administrator but still it's not working.  I have a basic Acurite 5 in 1
Photo of Karl Byriel

Karl Byriel

  • 11 Posts
  • 2 Reply Likes

Posted 2 years ago

  • 1
Photo of Michael Floden

Michael Floden

  • 114 Posts
  • 5 Reply Likes
Have you down loaded the latest version of the link program. I don't know what it is. But I bet you could find it in the knowledge base Q&A. Glad I didn't update to Windows 10.
Photo of Michael Floden

Michael Floden

  • 114 Posts
  • 5 Reply Likes
Found it they say to download AcuRite Connect Version 1.2.1 for Windows 10. Good luck.
Photo of Karl Byriel

Karl Byriel

  • 11 Posts
  • 2 Reply Likes
I have had it work on Windows 10 for a year but I just installed the Anniversary update and the link stopped working. I am using the latest version.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Karl,

We are sorry to hear that you are having problems. Are you using the AcuRite connect software on your computer?  If you have uninstalled, and reinstalled and it is still not coming up, then we would recommend contacting your computer manufacturer. Thank you. Have a good day!
Photo of Karl Byriel

Karl Byriel

  • 11 Posts
  • 2 Reply Likes
I managed to get it working by disabling my MalwareBytes Premium and my BitDefender.  Re-enabled after install and all works fine now.  Just strange as these programs never gave any problem previously.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6428 Posts
  • 200 Reply Likes
Hello Karl,

Thank you for the update.  We are happy to hear you are up and running.  Please feel free to contact us with any questions or concerns.  Thank you and have a great day!
Photo of zchopper62 .

zchopper62 .

  • 1 Post
  • 0 Reply Likes
I have been unable to get my 24C86E0722EF station to communicate after W10 update? Where is the link for V1.2.1? The only one that keeps downloading is v2.0.3???
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6428 Posts
  • 200 Reply Likes
Hello zchopper62,

To use PC Connect you will need v 2.0.3.  If you haven't already, please create an account on www.MyAcuRite.com
If you are using a PC Connect display please verify the display is on Mode 3. Verify you downloaded the new AcuRite PC Connect software and removed the previous software you had been using previously. Once this is done, PC Connect needs to be connected to add the MAC address/Device ID. Under Data Transfer you should check the box if you want automatic data transfers, then chose how often you would like them to transfer. Below you should see Weather Sharing, check the box that says Share my Weather Data, a box should appear asking for your Device ID, enter the 12 digit ID and click 'Share Now'. Under status you should see the display detected, below you should see a time stamp of the current data transfer. Below you should see My AcuRite Sharing Active. After this is set up you can click the plus button on My AcuRite and add your Display Device ID.  Please let us know if you have any questions.  Thank you and have a great day!