Wind speed on unit freezes up

  • 1
  • Question
  • Updated 3 years ago
I have a 5 in 1 pro. I live in Michigan, this winter we have had a couple of rain storms and now the wind indicator freezes up. Have taken it down and put iinside for a day to dry it out. Second rain and the wind drove water under the wind go arounder and now freezes up when temp below 32. Need a fix
Photo of Ron Retzloff

Ron Retzloff

  • 3 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Dan

Dan

  • 87 Posts
  • 15 Reply Likes
Wind go arounder?(Anemometer) I too live in MI and haven't had a problem, where do you have your 5n1 located? if you have it by buildings you could be getting a wind tunnel effect.
Photo of Ron Retzloff

Ron Retzloff

  • 3 Posts
  • 0 Reply Likes
It's is out in the open and al worked fine till the rain with wind.  I appears that water blows up into the area where the spinner rides on and then freezes.  I am thinking that a small spray up there with WD40 would keep it from freezing.  Or the spray they use on car door locks to free them up when they freeze.  Tired of taking it down to bring it in to thaw out and dry for a day to use again.
Photo of Dan

Dan

  • 87 Posts
  • 15 Reply Likes
Yes you could try the wd40 or a similar silicon spray something that would leave a slippery coating behind. Like I said I've never had this freeze issue, Strange.  
Photo of Harold Ashe

Harold Ashe, Champion

  • 1449 Posts
  • 312 Reply Likes

Old adage:  "If it moves but should not, use duct tape.  If it does not move but should, use WD40."

Actually, I have seen a couple of posts recommending Rem Oil (made for guns) which is a Teflon based product for really cold weather.

Photo of AcuRite Crystal

AcuRite Crystal

  • 2000 Posts
  • 111 Reply Likes
Hi Ron,

If your wind cups are freezing up on you, try using WD40 on the shaft under them to see if that resolves the problem.  If it doesn't, please call us at 877-221-1252.
Photo of Ron Retzloff

Ron Retzloff

  • 3 Posts
  • 0 Reply Likes
After taking down and putting inside overnight drying out, I gave it a small shot of WD40.  It has been working for the past two days without a problem.
Photo of Dan

Dan

  • 87 Posts
  • 15 Reply Likes
With the winter storms we're getting in the thumb of MI today a mix of sleet/snow then snow my 5n1 is iced over a bit but still performing well.
Photo of AcuRite Kevin

AcuRite Kevin

  • 1015 Posts
  • 73 Reply Likes
Ron and Dan,

Glad to hear your units are working well!  Have a great day!