Wind speed not working

  • 2
  • Problem
  • Updated 5 months ago
wind speed not registering on model 06058 display. the 5in 1 pro+ sensor model 06014 is sending out all the other information but no the wind speed. 
Photo of Gary Katz

Gary Katz

  • 2 Posts
  • 1 Reply Like

Posted 6 months ago

  • 2
Photo of Bill Martin

Bill Martin

  • 740 Posts
  • 125 Reply Likes
if you bring inside, can you manual spin cups and see wind speed?  is there anything preventing the cups from freely spinning?  if you carefully pull up, like you are going to take off the cups, do you feel something holding them down or do they just come off without any resistance?  you'll need to do more debugging/testing to uncover what is wrong.  it could be cups not engaged, it could be a bad sensor, it could be.....
Photo of Murray Stafford

Murray Stafford

  • 78 Posts
  • 27 Reply Likes
Is it frozen? We had an ice storm one time that prevented mine fromworking.
Photo of Gary Katz

Gary Katz

  • 2 Posts
  • 1 Reply Like
Cups are spinning great, it’s the wind speed information not being picked up by the display or being transmitted.
(Edited)
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6236 Posts
  • 198 Reply Likes
Hello Gary,
Please try the following battery recommendations and troubleshooting steps. If this does not correct the issue, please let us know. Thank you.



Batteries:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4°F/-20°C) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

Hard reset:



- Bring both units side by side and remove all batteries, unplug display if it has an ac adapter



- Change the ABC Switch to a different setting and ensure that both are on the same setting. example - If on A, move both to C



- Place batteries into the outdoor sensor first



- Place batteries into display



- Allow units to sit side by side until they connect.