Weather Underground sharing failed ??? 02064RX - 5 in 1 weather station

  • 1
  • Problem
  • Updated 1 year ago
I have been having problems for over a month now. My system tells me that weather underground sharing failed. And it has. I keep checking wunderground and my station is nowhere to be found.I have even tried switching usb ports. I tried re-installing the acurite software ... Next step may be in returning the unit for warranty, it's not 3 months old yet. A registered Christmas present 02064RX / 5 in 1
Photo of Gregory Gee

Gregory Gee

  • 2 Posts
  • 0 Reply Likes
  • Very, very frustrated

Posted 1 year ago

  • 1
Photo of Gene

Gene

  • 76 Posts
  • 13 Reply Likes
First check here if you can find your weather station

https://www.wunderground.com/personal-weather-station/mypws

If you can't, try creating a new one. In any case check that you are using the right station ID here.

https://www.myacurite.com/#/share-weather
(Edited)
Photo of Harold Ashe

Harold Ashe, Champion

  • 1449 Posts
  • 312 Reply Likes
Good advice from Eugene.  Make sure you registered your station with WU using all capital letters and that your password is correct and that you checked the box in myAcurite to allow data sharing
Photo of Gregory Gee

Gregory Gee

  • 2 Posts
  • 0 Reply Likes
Yep. Still there. Used to send data, just hasn't been for over a month now. Everything is set where it should be ... (?)
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Gregory,

Make sure you are typing in the station ID and password and not copying and pasting it. Some users have had luck using station ID and password and some have had luck using station ID and pass key.  We would recommend trying both. Make sure you are entering the credentials into the software only, and not on My AcuRite. Thank you.