The red light stays on constantly on my Acurite Thermometer - #00782W3.

  • 1
  • Problem
  • Updated 9 months ago
The red light on my Acurite Thermometer - Model #00782W3 - stays on constantly. Changed the batteries, but the red light will not blink, and I do not get a temperature on the display. Any one out there that can help?
Photo of Tina Stewart

Tina Stewart

  • 1 Post
  • 0 Reply Likes

Posted 9 months ago

  • 1
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Tina,

If the red light on the sensor will not go off, this indicates that the sensor is not transmitting. It would need to be replacing. Make sure you are following the battery guidelines below: 

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

Remove the batteries for about 2 minutes, and if the red light does not flash and you have had the sensor more than one year we would recommend replacing the sensor. If you have had it less than one year, we would initiate a warranty claim. We have attached the link to the replacement sensor.

https://www.acurite.com/replacement-sensor-606tx.html
Photo of David Smith

David Smith

  • 2 Posts
  • 0 Reply Likes
I also have this issue
The freezer sensor worked for a few days and now a solid red light
using fresh Kirkland alkaline batteries and I changed them to a new set
I removed them for 5 minutes 
I have the unit less than one week

model 00986
(Edited)
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello David,

When you get the red lights do you see the dashes for the information or do you get a temperature reading? Please remove the batteries from all 3 products and try the steps below: 

  1. Bring all 3 units together, side by side.
  2. Remove the batteries from all 3 units.
  3. Press the reset button located next to the C/F switch on the bottom of the display. Press this for about 10 seconds.
  4. Place the batteries into the main unit first.
  5. Place the batteries into sensor #1.
  6. Place the batteries into sensor #2.
  7. Press the reset button on the display again for 10 seconds.
  8. The main unit should read temperatures from both sensors almost instantly.
If this does not correct the issue we would then initiate a warranty claim on the thermometer. Where was it purchased?