temperature on the display is frozen

  • 1
  • Problem
  • Updated 2 years ago
The temperature reading on my display is frozen for a few weeks now,  staying at 47 low and 99 high.  also it shows rain all the time now, even though it is mostly sunny here in California. How can I correct that?
Photo of Helga Martinez

Helga Martinez

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Helga,

What is the model number of the display in which you are referring to? Thank you.
Photo of dennis odowd

dennis odowd

  • 1 Post
  • 0 Reply Likes
Jennifer,
I am having the same problem. Have a 1036CA1 display, along with an older monochrome display, both recieving from the same 5 in 1 wireless multi sensor. Outside wind and rain readings appear to be correct. Temperature on both displays has been frozen at 39 degrees for the past five days. Battery level is high.
Photo of Helga Martinez

Helga Martinez

  • 2 Posts
  • 0 Reply Likes

Hello Jennifer, 

the model number is 01035

Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Dennis & Helga,

We would recommend doing these steps when your local pressure is at 29.92.  This will start the learning mode over on your display. You may see inaccurate forecast and pressure readings until the 14 day learning mode is complete. 



  1. Bring both the sensor and display unit indoors side by side.
  2. Remove batteries from the sensor.
  3. Remove batteries from the display unit and unplug the AC adapter (if applicable).
  4. Wait 1 minute to ensure any remaining battery power is discharged from both units. 
  5. Change the A-B-C channel on both the display and sensor making sure they both match.
  6. Reinstall batteries in outdoor sensor first.
  7. Reinstall batteries in display unit second.
  8. Let the units sit within a couple feet of each other for 20 minutes to ensure a wireless signal is received. 
    * The display should receive the signal within several minutes. 
  9. After a connection has been established you may place the sensor outdoors.
    *If the signal connection fails after the units are separated try a new or different location for the display unit, the sensor or both.