Solution to my problems with Waiting for Data, PC Connect software for Windows

  • 4
  • Problem
  • Updated 5 months ago
I setup PC Connect on my computer and had nothing but problems getting the software to share data with My AcuRite and Weather Underground. The software would detect the indoor display and was receiving data as indicated by the Last Data Received time stamp. I also logged at the file created by the data transfer. It contained valid data so the software and weather station were successfully communicating with each other.

The problem I had was trying to get the PC Connect software to report data to My Acurite or Weather Underground. I would constantly get the status message "Waiting for Data" It would never change to Data Sending. I also noticed that the color of the Device ID text would stay Red, indicating there was a problem with the Device ID. I tried everything to get it to connect, uninstalled and reinstalled the software, verified that the station was in USB mode 3, disconnected and reconnected the USB cable, tried a different USB port. I finally discovered by mistake that if I entered the Device ID and then put an extra letter at the end, then backspaced or deleted that extra letter that the text turned Green. After doing that the PC Connect software finally connected and the status changed from "Waiting for Data" to "Data Sending"!

I found that I had to do the same thing to get the Weather Underground sharing to work. I entered my Weather Underground Station ID and and Station Key. I put an extra number at the end of both then backspaced or deleted the extra number and it started sharing data.

This seems to be a bug within the PC Connect software and a very frustrating one at that. I am a software developer for a living and know that these types of bugs happen and can be very difficult to narrow down. I hope that this info helps others with sharing problems and helps Acurite improve the software making it easier for people to get setup. It took me a good 12 hours of fiddling with the software to finally get setup.

For those that are trying to troubleshoot connection issues there is a LOG file that Acurite PC Connect creates that is a godsend. The LOG file is located under the Chaney Instrument Co folder on your Local Disk (C:). When examining the LOG the URL that the software was trying to post data to was leaving the last letter or number off the Station ID. Look for lines that start with "Preparing to post:" you will see in the URL ID=xxxxxxxxx. Verify that it has the correct ID for both Acurite and Weather Underground. The Weather Underground URL also contains your password (Station Key), in my case I found the last number was dropped for both Station ID and Password (Station Key). If the log file is crazy long making it hard to navigate, rename the file or delete it and the software will create a new LOG with the newest data.

I am running Windows 7 with PC Connect version 2.0.3
Photo of Jonathan Sherman

Jonathan Sherman

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 4
Photo of captnsea

captnsea

  • 11 Posts
  • 0 Reply Likes
Wow...  Lots of "fiddling"..  Great to see these "posts".  My WS is supposed to be under the "tree"  in a few weeks.  Can't wait to get setup..  Switching from Lacrosse as my current system continues to fail after about five years.  Hope I'm making the right switch.  I actually live in Sherman, CT.  All the best..
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Jonathan,

Thank you for the feedback. We tried to replicate the problem you experienced and were not able to do so. Did you copy and paste the information or enter it in yourself?  With the further details we will see if we are able to replicate this. If so then we will investigate it and find a resolution. Thank you. Enjoy your day!
Photo of Jonathan Sherman

Jonathan Sherman

  • 5 Posts
  • 0 Reply Likes
I had tried both manually typing the information and copy paste. The only thing special is how I access the computer running the PC Connect software. The computer is in a location that is hard to access directly so I use Microsoft Remote Desktop to remotely connect to the computer. This is a feature that is built into the Windows operating system. I use the Microsoft RD Client for Apple IOS to connect to the computer from my iPhone or iPad. I experienced the same problem from both the iPad and iPhone. Because of the difficulty accessing the computer directly I did not try inputting the information using the keyboard and mouse. I only tried using a Remote Desktop connection.

If you would like more information just let me know.

Thanks!!
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Jonathan,

Thank you for letting us know. I personally have tried on different computers that we have here and have not been able to replicate the problem. This sounds like an isolated incident. Does this happen every time you open the software.  You should only have to enter your credentials once on the software. Thank you. Enjoy your day!
Photo of Mark

Mark

  • 5 Posts
  • 1 Reply Like
I had a similar issue.  My WX station was not communicating. I tried multiple resets of the console and reboot but to no avail.  I altered the the station ID and changed it back as suggested by Jonathon and it started working so this doe not seem to be an "isolated incident. 

Thanks Jonathon for the suggestion!

Mark
Photo of Jonathan Sherman

Jonathan Sherman

  • 5 Posts
  • 0 Reply Likes
Thank you for letting me know it helped you out!
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 5922 Posts
  • 189 Reply Likes
Hello Mark,We are happy to hear you are up and running. Please let us know if you have any other questions. Thank you and have a great day!
(Edited)
Photo of Jonathan Sherman

Jonathan Sherman

  • 5 Posts
  • 0 Reply Likes
The issue only happens when initially setting the software up. Once it's working it continues to work without any problem after restarting the software or the computer.

Just to verify it wasn't a fluke I uninstalled the software and reinstalled it. I ran into the same exact issue with the fresh install. It was very difficult getting it working again and immediately regretted the decision to uninstall and reinstall trying to recreate the issue.

Glad I was able to help you out Mark! If my feedback here helps anyone out it was totally worth my time sharing. Thank you!!
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6127 Posts
  • 194 Reply Likes
Hello Jonathan,Thank you for sharing your experience and solution. This is certainly helping other customers resolve their issues. Please let us know if you have any questions. Thank you and have a great day!
Photo of captnsea

captnsea

  • 11 Posts
  • 0 Reply Likes
So, I'm getting a Dual Display & 5-in-1 Weather Environment System with PC Connect and My AcuRite for Christmas.  Does it always have to be attached to a PC?  Or, can it communicate wirelessly?  Can't quite figure it out from the manuals I've downloaded.  Please let me know.  Thanks..
Photo of Jonathan Sherman

Jonathan Sherman

  • 5 Posts
  • 0 Reply Likes
The display requires a connection to a computer to transfer data logs and to provide live data to the PC connect software to share with MyAcuRite and weather underground. You can use a acurite smarthub to share your weather data without a computer. I don't have a smarthub so I cannot share my experiences using one or it's exact capabilities.

You can search acurite's page for SmartHub to read more about it if the link here does't work: https://www.acurite.com/smarthub-for-...
Photo of captnsea

captnsea

  • 11 Posts
  • 0 Reply Likes
Many thanks.  My system is coming with a Smart Hub.  Thank you again.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 5960 Posts
  • 190 Reply Likes
Hello captnsea,If your bundle is coming with a smartHUB, the smartHUB will connect to your router with an Ethernet cable and send the data through the router bypassing a computer completely. Please let us know if you have any other questions. Thank you and have a great day!
Photo of CptZenon

CptZenon

  • 2 Posts
  • 0 Reply Likes
I was having a similar issue and looked at the LOG file on mine and it appears to not post data when the RSSI = 0. It is deceiving to see it say that data is being received, but then no data is being shared without an explanation.
Photo of frankfaris

frankfaris

  • 1 Post
  • 0 Reply Likes
May 18, 2017.  After months of proper operation, I just experienced this problem and this tip fixed it.  I am surprised that the problem has been around this long without a proper software fix.
Photo of AcuRite Tori

AcuRite Tori

  • 1368 Posts
  • 50 Reply Likes
Hello Frankfaris,

We are happy to hear that you were able to get this corrected. Have a great day!
Photo of John Wenger

John Wenger

  • 1 Post
  • 0 Reply Likes
I am having this issue bad. Whenever I start PC Connect it opens and the device ID is black and no updates to My Acurite. I add a character to the device ID and then backspace and it turns green.

After that, one time only, it updated to My Acurite. Now it just says Waiting for Data.

Also, I've registered the device with WeatherUnderground. Did the add a character and backspace on both the station ID and password but it has never sent data there.

I also registered the Weather Underground station ID and password on the My Acurite website. This has my confused on whether WU is updated from My Acurite website or directly from PC Connect!

This software should be super simple and easy. But it is really confusing, difficult, and doesn't seem to work well at all. Frustrating that these issues have been going on for at least 6 months and nothing is being done!

John
Lowell, MI  USA
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 535 Reply Likes
Hello John,

We are sorry to hear you are having some issues. On the device ID it should start with 24C86E and have 6 digits or numbers after it. Can you confirm that is what you are seeing in the software? We can see that you are transmitting to Weather Underground and My AcuRite at this time. After the Device Id make sure there are no spaces after it as well.
Photo of Carey Willis

Carey Willis

  • 3 Posts
  • 0 Reply Likes
My acurite will not transfer data.  I have cleared all my data both from the computer and from the display.  It shows my status as detected but cannot transfer data.  This is a problem everytime the computer gets shut off or the power flicks.  Your software really needs to have this glitch repaired.  This is frustrating to have to go through this constantly.
Carey
New Bern, NC
Photo of AcuRite Tori

AcuRite Tori

  • 1368 Posts
  • 50 Reply Likes
Hello Carey,

Can you please provide us with your model number so that we are able to further assist you? Thank you.
Photo of Carey Willis

Carey Willis

  • 3 Posts
  • 0 Reply Likes
I have the 5 in 1 acurite 01036 pro weather station. 
Photo of AcuRite Tori

AcuRite Tori

  • 1368 Posts
  • 50 Reply Likes
Hello Carey,

 What USB mode is your display console on? Thank you.
Photo of Carey Willis

Carey Willis

  • 3 Posts
  • 0 Reply Likes
USB 3  It just says waiting for data and will not do anything else.  I have now disconnected it from my windows computer and connected to my mac and still the same thing.  If have removed batteries and killed power for 5 minutes and still no solution.
(Edited)
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 535 Reply Likes
Hello Carey,

Have you been able to transfer the data before into a CSV file? The PC Connect software is something our development team is looking into.  Please try the steps below as well.  After you reset the display make sure to put it back to USB mode 3. You will want to wait a couple of hours for the display to collect data, and then try to transfer it.

To do a factory reset: (THIS WILL CLEAR ALL OF YOUR HISTORY AND YOUR SETTINGS)

Please verify that you are using a name brand (Rayovac or Energizer) standardalkaline batteries in the display unit. We do not recommend using anything thatis heavy duty, rechargeable, store brand or Lithium inside of the display.

- Remove all power, AC adapter and batteries, from the display unit.
- Press and hold down the pin hole reset button, located in the batterycompartment, for 20 seconds.
- Plug back into AC power and insert recommended batteries.
- Press and hold down the pin hole reset button for an additional 20seconds.
- Verify that the unit has powered on and once connection has been made,attempt to set time and date.
Photo of Weather Mike

Weather Mike

  • 26 Posts
  • 4 Reply Likes
I have The 01092, but it is irrelevant which model one has.  The PC Connect software does have an issue.  I spoke to a representative yesterday on the phone about this issue.  I told her that after a computer reboot the PC Connect software automatically comes up and detects the display then hangs until I add a letter or number after the 12 digit device ID then backspace it out.  The ID turns from black to green and begins sharing data.  I have to do the same thing for my weather station ID, then everything works.  The representative asked if I hit stop sharing before closing the program?  I told her no because this is hooked up to an old laptop without a battery expressly for this purpose and the only time it will reboot is if I lose power.  She then told me, "Hitting the Stop Sharing button on the software is the same thing as adding a letter or number then backspacing."  Really?! Hmmm...  I tried stop sharing, then rebooted...guess what happened?  Yep...It worked after I hit the "Start Sharing" button again.  The ID never turned green either unless I added a character then backspaced it out...it was working though.  Unfortunately, in my case, It will hang after a reboot until I intervene.  So having this be an automatic solution after a power outage?...Well, it's not going to happen.  I have easily duplicated this issue in the Mac version and Windows 7, 8, 8.1, and 10.
I have PC Connect version 2.0.3 for windows currently.  It is not Operating System specific.  There is a problem with this program restarting without manual intervention.  This kind of takes the fun out of it for me during a power outage. I didn't want to use the Smart Hub because I wanted my data transferred every 35 seconds with PC Connect.  I believe the Smart Hub will only transfer every 15 minutes to WU....sadly.  So, DO NOT use PC Connect if you need your data to automatically start re-transmitting to WU after a power failure unless you are sitting at your computer 24X7.
(Edited)
Photo of AcuRite Tori

AcuRite Tori

  • 1368 Posts
  • 50 Reply Likes
Hello Weather Mike,

 The purpose of AcuRite PC connect is to constantly have the computer running in order to actively stream your data. When the computer is rebooted or there is an update causing interruption in streaming this may require you to stop and then resume sharing on the software. The SmartHUB will update every 5 minutes to My AcuRite and every 36 seconds on Weather Underground.
Photo of Weather Mike

Weather Mike

  • 26 Posts
  • 4 Reply Likes
Tori,
Thank you for the update on this issue.  I am happy to hear that the SmartHub will post my data every 36 seconds rather than 15 minutes to weather underground.  I held off purchasing one for that reason alone.  I just purchased one from your website.  Hopefully this will resolve my issues.
Photo of Larry

Larry

  • 3 Posts
  • 0 Reply Likes
I am having the same problem. For days I have tried to connect and the message is still "Waiting for Data." I have tried every solution listed from this thread and cannot get my unit to connect. 
Photo of AcuRite Jennifer

AcuRite Jennifer, Employee

  • 11263 Posts
  • 500 Reply Likes
Hello Larry,

What is the model number of your weather station? Are you using PC Connect for Windows or Mac?  What version of the PC Connect software do you have installed? What is the operating system on your computer? If your display has a USB mode make sure you have it in USB mode 3.  Where was the weather station purchased, and how long have you had it? Thank you for providing us with this information.
Photo of Chuck Cvitkovich

Chuck Cvitkovich

  • 3 Posts
  • 0 Reply Likes
I am having the same problem.  I've had this weather station running for years, then yesterday all of a sudden I get the dreaded "Waiting for Data" message.  The version of the software is 2.03 on a Windows 10 pc running USB Mode 3.  I am not sure what model the weather station is - it's a 5-in-1.  It was purchased from Acurite.  I have uninstalled, rebooted the pc, reinstalled the software several times.  IT didn't help.

Follow up - I replaced the unit with fresh batteries, that didn't make a change.  Then I 'refreshed' the unit, it is now reporting everywhere but to MyAcurite.  Weather Underground is receiving updates.  PC Connect is reporting 'sending data' but MyAcurite is showing the unit is offline.

Further Follow Up - After not seeing any change in the MyAcurite site and the inability to get the unit to show 'online', I removed the device definition from MyAcurite and re-entered the information.  That worked - the unit is now showing as being online and reporting correct information.  Not sure what happened, but resetting everything has everything back to normal.
(Edited)
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 5733 Posts
  • 182 Reply Likes
Hello Chuck,

We can see you are currently updating on My AcuRite. Please let us know if you have any other questions. Thank you.
Photo of Daniel Garcia

Daniel Garcia

  • 1 Post
  • 0 Reply Likes
Yes it worked!!  Thank you!