smarthub wont stay connected

  • 1
  • Problem
  • Updated 2 months ago
Ok, seriously Acurite you need to get your shit together. I've spent over a week trying to call to resolve this, and have ran into an automated message saying, "I'm sorry, we're experiencing a phone issue, please call back"  at random, I've gotten through to a tech who wanted to pass me along to "Tier 2" tech support, and dropped the call, AFTER waiting over a hour on hold, and I just call again, IN THE MIDDLE OF THE DAY, and reached an automated message that said, sorry, due to (some issue), there are no techs available to take you call. Please log onto our website and check our call hours" which just so happen to be 7am to 5pm, ITS 1:30PM!!!

My smarthub (09150M) won't stay connected to any (3) or my sensors, and I've searched and followed all of the advice from the support forum, and it seems to be terminal.  

Please PLEASE get me someone who can setup a warranty exchange, or, since you're abandoning service for the smarthub, maybe we can reach an agreement to upgrade at reduced price.  
Photo of Jonathan weber

Jonathan weber

  • 6 Posts
  • 1 Reply Like

Posted 5 months ago

  • 1
Photo of Jonathan weber

Jonathan weber

  • 6 Posts
  • 1 Reply Like
Are you kidding me???? Given that no one from Acurite has replied, I tried calling again, and just spent FOUR HOURS on hold, to go from # 24, to #1 waiting in line, then to hear a dial tone, and the same damn recorded message saying, "Sorry, due to technical difficulties, we are unable to take your call". 

What good is a warranty if I literally cannot get a hold of ANYONE at Acurite?? This is borderline criminal!

I guess I'll just be here, waiting for someone to maybe hopefully help me, at some point....
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6284 Posts
  • 199 Reply Likes
Hello Jonathan,
We are very sorry for any inconvenience you have experienced trying to reach the AcuRite Support Team.  Due to the overwhelming response to the launch of the new AcuRite Access, our call volume has greatly increased.  I can see you are currently offline on My AcuRite.  What are the lights on the smartHUB doing? Do you have the smartHUB connected directly into your router or are you using a switch of any kind? The smartHUB requires a direct router connection. Please power cycle your smartHUB and router. To do this, you will unplug your Ethernet cable from the router then the adapter for the HUB. After this you can unplug your router. Please leave them unplugged for about 5 minutes. When you plug them back in plug the router in first and let it completely boot up, then you can plug the Ethernet cable into the router after that the adapter.  Please let us know if the issue continues. Thank you.
Photo of Jonathan weber

Jonathan weber

  • 6 Posts
  • 1 Reply Like
Hello, and thank you for the response.

First off, let me say that I was considering upgrading to the Access, but with the trouble I've had with the smartHUB, and the absolutely terrible customer service I've received so far, I am reconsidering another brand of weather station altogether. Please prove me wrong.

Yes my smartHub is offline. The sensor status light blinks repeatedly at one second intervals.  The smartHub is plugged directly into the router, and the setup I have worked perfectly for over 6 months, and nothing had changed since then.

I've already tried your recommendation to power cycle the smartHub and router, honestly at this point I've done it in excess of 5 times.  When I do, it works anywhere from an hour to 3 hours, and then the sensor light goes back to rapidly blinking.

I just received an email asking me to upgrade again, with the promotion ending March 31st.  Given that my smartHub is under warranty, and I'm certain it needs to be replaced, it makes sense to me, rather than sending me a smartHub which Acurite will only provide service until Feb. 2019, that I could just upgrade to the Access now. Having said that, I'm still so disappointed in the customer service I've received so far that I'm not sure I don't want to cut my losses and try another company who values their customers.  

To be clear- my smartHub has not worked in over 2 months at this point, I've easily spent over 10 hours researching and trying to fix it myself, and another 5 or so hours tying to contact Acurite to resolve this. I'm desperate to resolve this. 
Photo of Jonathan weber

Jonathan weber

  • 6 Posts
  • 1 Reply Like
Anything? I can't believe you expect me to buy another piece of Acurite equipment when the one I have is UNDER WARRANTY and can't get any sort of assistance getting the issue resolved.

If this is not taken care of before my warranty does run out, I will consider legal action. The customer service I have received is appalling, and that's being nice.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6284 Posts
  • 199 Reply Likes
Hello Jonathan,
We have emailed you at the email address on file regarding this issue. We are very sorry for the delay. We will get this resolved together. Thank you.
Photo of John Beattie

John Beattie

  • 17 Posts
  • 2 Reply Likes
Interesting that a customer has to threaten legal action to get a response.  I'd be interested to see if Jonathan's problem was resolved.  Jonathan can you post to the thread and let us know?
Photo of Jonathan Weber

Jonathan Weber

  • 1 Post
  • 1 Reply Like
I will write a more detailed follow-up upon resolution, but as a quick update, after almost 5 months of trying to get ahold of Acurite to have them honor their warranty, I was contacted by email by a polite representative. Although I had posted in detail all the specific symptoms and all the ways in which I had already tried to troubleshoot the issue myself, she still had me run through all the standard steps posted 100 times over in these forums. After confirming the problem remained, I was told to package the smartHUB and send it in, which I did at my expense. Once they received it, I received another email. A few days later, another email, this one stating there was in fact a problem, and supposedly they fixed it. I am now waiting for it to be returned. Time will tell.