set button not working

  • 1
  • Problem
  • Updated 5 months ago
Model # 00621W2 - Batteries died in the wall unit.  Changed them and also changed the ones in the outdoor unit.  Display unit now reads the number 8 everywhere.  Tried to reset so we could set the time.  But now set button has no effect on the display.  We also changed the CR2032 in hopes that this would solve the issue.  Still no change.  Also we left the batteries out of both units for 10 minutes and then put them back in, hoping to reset that way.  The reset button in the battery compartment is working, the screen goes blank when we pushed it.  Although, still reading 8's everywhere and set button still does not have any effect.  Please help.  
Photo of Sherry Doug Squires

Sherry Doug Squires

  • 1 Post
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6236 Posts
  • 198 Reply Likes
Hello Sherry,
Please verify you are following the battery recommendations and try the troubleshooting steps listed below. If this does not correct the issue, when and where was this purchased?  Thank you.

To do a pinhole reset: (THIS WILL CLEAR ALL OF YOUR HISTORY AND YOUR SETTINGS)

Please verify that you are using a name brand (Rayovac or Energizer) standard alkaline batteries in the display unit. We do not recommend using anything that is heavy duty, rechargeable, store brand or Lithium inside of the display.

- Remove all power, AC adapter and batteries from the display unit.
- Press and hold down the pin hole reset button, located in the battery compartment, for 20 seconds.
- Plug back into AC power and insert recommended batteries.
- Press and hold down the pin hole reset button for an additional 20 seconds.
- Verify that the unit has powered on and once connection has been made, attempt to set time and date.