screen for sensor 2 not working. new device.

  • 1
  • Problem
  • Updated 3 years ago
Hello. I bought a 00986 digital thermometer. I installed new alkaline batteries in one sensor and two lithium batteries in the other sensor and the batteries in the temperature reader. The displays shows the temperature of sensor  1 but does not show the actual temperature of sensor 2. However, it does display max and min in both sensors. Is the scree defective?
Photo of drtarajia

drtarajia

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of AcuRite Mike

AcuRite Mike

  • 400 Posts
  • 11 Reply Likes
Hello drtarajia,

Are you noticing "- -" to appear on sensor #2's readout?

This would indicate the display unit is not receiving any data from sensor #2.

Have you tried using all alkaline batteries in both sensors to see if the issue persists?
Photo of drtarajia

drtarajia

  • 3 Posts
  • 0 Reply Likes
Hello
It does not show any line, totally blank. I have used alkaline batteries, switching sensor 1 to freezer does make it show sensor 1 temperature. Then sensor 2 in the refrigerator with alkaline batteries stays the same on the screen. Perhaps the screen is damaged?
Photo of AcuRite Mike

AcuRite Mike

  • 400 Posts
  • 11 Reply Likes
Hi drtarajia,

You may want to try removing the batteries from the display unit, pressing and holding the "Reset" button for 3-5 seconds, reinstalling batteries in the display unit and then pressing and holding the "Reset" button again for 3-5 seconds. Once this has been completed you may perform another reset using the reset guide below.

  1. Bring all 3 units together, side-by-side.
  2. Remove all batteries from all 3 units.
  3. Reinstall batteries into main unit first.
  4. Reinstall batteries into sensor #1.
  5. Reinstall batteries into sensor #2.
  6. The main unit should read temperatures from both sensors within 2 minutes.
 Hopefully this will help. Please keep us updated.
Photo of drtarajia

drtarajia

  • 3 Posts
  • 0 Reply Likes
Hello
Tried different things as suggested above, never worked. I returned the item for a new one and the new one is working correctly. thanks
Photo of AcuRite Mike

AcuRite Mike

  • 400 Posts
  • 11 Reply Likes
Hello drtarajia,

Thank you for updating us on this and we are happy to hear the new one is working properly for you. Please feel free to reach out to us if you have any other questions or concerns.