Purchased Acurite model 02064C/999143 rain display not working

  • 1
  • Problem
  • Updated 1 day ago
Purchased Acurite model 02064C/999143 rain display not working out of the box, everything else works fine, already tried everything I have read here including taking batteries out and putting them back as mentioned here with no results, is there a fix for the rain display problem? Larry
Photo of Larry Chandler

Larry Chandler

  • 4 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 1
Photo of PSL5082

PSL5082

  • 56 Posts
  • 14 Reply Likes
There is likely a rain gauge stabilizer taped to the bottom of the unit for shipping that should be removed. Maybe that's the problem?
Photo of Larry Chandler

Larry Chandler

  • 4 Posts
  • 0 Reply Likes
I removed the stabilizer before I started anything else. I have been reading other people with the same problem rain gauge not responding. There must be an on going problem with this part of the unit, and people have been waiting for a fix to the problem, please let me know what I can do before I put a rating on unit.
Photo of Larry Chandler

Larry Chandler

  • 4 Posts
  • 0 Reply Likes
I have exhausted everything doing all battery reinstallations sensor first then display , tried reset button, nothing has worked to get rain display to show anything in rain sensor, everything else works. Help! Larry Chandler
Photo of Larry Chandler

Larry Chandler

  • 4 Posts
  • 0 Reply Likes
I have an older acurite weather system that worked great for 7 years, but this one has had the rainfall problem out of the box model 02064C. Help! Larry Chandler