Outdoor Temperature Not Correct

  • 1
  • Question
  • Updated 2 years ago
Help, it's in the 80's right now. Is this broken?

Note: This conversation was created from a reply on: Support Closed Wednesday June 29th.
Photo of John Benjamin

John Benjamin

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes

Hello John,

We would recommend following the battery guidelines below: 

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

If you are following those battery guidelines I would recommend resetting the display and sensor by following the instructions below: 

“1.Bring both the sensor and display unit indoors and position them side by side.
2.Remove all batteries from the sensor.
3.Remove all power from the display unit.
4.Wait 1 minute to ensure that any remaining battery power has discharged from both units.
5.Inside each battery compartment you'll find an A-B-C switch, be sure these match each other.  You may also want to try changing to a different setting.
6.Reinstall batteries in outdoor sensor first.
7.Reinstall batteries (and/or connect AC adapter) in display last.
8.Let units sit within a couple feet of each other for 5 minutes to ensure a wireless signal is received.
 *The display should receive the signal within several minutes.
9.After a connection has been established you may place the sensor outdoors.
*If the signal connection fails after the units are separated try a new location for the display unit, the sensor or both.


If you continue to experience an issue please let us know here or you can call AcuRite Customer Support at 877-221-1252.  Thank you and have a great day!