NO WINDSPEED, DIRECTION OR RAINFALL READINGS AT ALL VERY FRUSTRATED!!!!!!

  • 1
  • Problem
  • Updated 3 years ago
I replaced my 5 in 1 after 2 great years because when  changing batters in outdoor sensor unit the wind vanes broke off due to UV degradation.
Bout a new01036 color unit and after resetting and replacing batteries and checking everything the manual told me I still have no wind speed indication. The wind vanes are turning. I've called the vendor and they are sending me a whole new Station (Thanks to their 90 guarantee, Cabela's) and then they will let me send this non-working one back for credit. (since I've now paid for two).
Question: WHat if this one doesn't work either???????
Also:It's not to reasuring to the customer that the customer support # answers, gives you the standard "this call may be......" and then hangs up on you. It happens with the acurite # and the Chaney Instruments # and also the website also gives your web browser "fatal error" messages on both Windows Firefox and Apple Safari and even the Cabela's Customer service person's attempt. Hope this is not an omen of things to come. My first weather station was so great. I am still hopeful?????????
Photo of Stanley Nelson

Stanley Nelson

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of AcuRite Crystal

AcuRite Crystal

  • 2000 Posts
  • 111 Reply Likes
Hi Stanley,

We are sorry to hear that you had difficulties accessing our website over the weekend, we will be sure to look into this.  In regards to the phones, we are open M-F 7am - 7pm CST which is why you were unable to reach us over the weekend.

In regards to your weather station not registering rain, most issues can be resolved with basic troubleshooting that we would be happy to assist you with.  Please let us know if you have any questions regarding your new weather station and we would be happy to help you.

Have a great day!