No wind speed and direction, outdoor temperature or humidity indicated on display for 5-in-1 weather sensor.

  • 2
  • Problem
  • Updated 3 months ago

I have received an AcuRite 5-in-1 Pro+ Weather Sensor and Display as a Christmas Gift.  The display has dashes for: outdoor temperature and Humidity and wind speed.  I have called three times for technical assistance and all three times I did not speak with a human at the company.  I am very disappointed with the customer service.  Does anyone know how to reach a representative to speak with about the issues I am experiencing?

Photo of Bruce Ramsey

Bruce Ramsey

  • 6 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 2
Photo of David P Naylor Sr

David P Naylor Sr

  • 45 Posts
  • 14 Reply Likes
make sure your switches in both outside and inside units are set  the same    a   b or  c   both MUST be in the same position   
Photo of Bruce Ramsey

Bruce Ramsey

  • 6 Posts
  • 0 Reply Likes

They are both set to the same channel, in fact I have tried all three channels to see if one would work better than the rest.  I have also tried hard reset after changing the channels.

Photo of David P Naylor Sr

David P Naylor Sr

  • 45 Posts
  • 14 Reply Likes
well sorry to say i think you got a defective unit    
Photo of Bruce Ramsey

Bruce Ramsey

  • 6 Posts
  • 0 Reply Likes
Thanks for your comments David.  Do you have any suggestions as to how to contact AcuRite.  I have called three time s and have no success in speaking with anyone.
Photo of David P Naylor Sr

David P Naylor Sr

  • 45 Posts
  • 14 Reply Likes
As someone they where closed today. So try Monday. I contacted them through this site. Acurite s website does have a phone number. And contact us section. Ihad to send mine back. Took two weeks to get it returned. Good luck. If I can help. Let me know. And how you make out
Photo of Bill Martin

Bill Martin

  • 728 Posts
  • 124 Reply Likes
best to post here and on both of the FB groups.  I know that various Acurite individuals do monitor these sites.  Rather than 1 place, increase odds at 3 places.
Photo of Bruce Ramsey

Bruce Ramsey

  • 6 Posts
  • 0 Reply Likes
Thanks for your suggestion Bill.
Photo of Ledrak

Ledrak

  • 1418 Posts
  • 314 Reply Likes
Bruce  Acurite was closed today you may need to wait until Monday for an answer. Just a thought but the order the units are powered up matters. You could try bringing the display out near the 5 in 1 and remove all power from the display, leave the 5 in 1 running (I'm guessing its mounted ) Now power up the display and see if it finds the sensor (the sensor needs to be powered up first) One more thing the batteries in the 5 in 1 can be tricky make sure you have the polarity correct. 
Photo of Bruce Ramsey

Bruce Ramsey

  • 6 Posts
  • 0 Reply Likes

What are their hours of operation? 

I have brought the sensor in the house and put next to display.  I have powered up the unit in the order you suggest for each channel.  When I changed the channels I completely turned power off (removed batteries from both 5-in-1 Sensor & Display and unplugged power for Display).  I suspect a defective unit, but do not know if it is Sensor or Display.  How do I go about returning it?

Photo of Ledrak

Ledrak

  • 1418 Posts
  • 314 Reply Likes
Bruce Acurite was closed Friday because of weather they should be open tomorrow as it says on the first page of this forum         "Our AcuRite Loyalty team monitors and supports this forum.
Mon-Fri: 7:00am - 5:00pm CT

CONTACT US: (262)249-3259 "  hopefully someone will be able to help you out then.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Bruce,

We are sorry to hear you had a hard time reaching us. We would be more than happy to assist you with your station. Has the station always showed dashes or at some point did you get an outdoor reading? Please try the hard reset steps below in the order they are listed.

You want the display and sensor to be at least 3 feet from electronics such as televisions, microwaves, computers & radios.  Follow the battery guidelines below:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

If you are following the battery guidelines perform the hard reset steps below:

1.Bring both the sensor and display unit indoors and position them side by side.

2.Remove all batteries from the sensor.

3.Remove all power from the display unit including the adapter (if applicable)

4.Wait 1 minute to ensure that any remaining battery power has discharged from both units.

5.Inside each battery compartment you'll find an A-B-C switch, change the channel to the next setting making sure they both match.

6.Reinstall batteries in outdoor sensor first.

7.Reinstall batteries (and/or connect AC adapter) in display last.

8.Let units sit within a couple feet of each other for 3 minutes to ensure a wireless signal is received.
*The display should receive the signal within several minutes.

9.After a connection has been established you may place the sensor outdoors.
 *If the signal connection fails after the units are separated try a new location for the display unit, the sensor or both.

If this does not correct the issue please let us know.


Photo of David P Naylor Sr

David P Naylor Sr

  • 45 Posts
  • 14 Reply Likes
I just love the scripted replies you get from acurite. Like we are all a bunch of idiots, that was the same reply I got for a completely different problem. Over and over
Photo of Bruce Ramsey

Bruce Ramsey

  • 6 Posts
  • 0 Reply Likes

AccuRite Jennifer.  I have repeated the process in order at least 6 times (twice per channel).  The results are the same.  Dashes on the display for the outdoor readings.  What do you suggest next?

Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Bruce,

We have emailed you at the address on file. Please check your inbox.