My AcuRite 5 in ! stopped reporting rain.

  • 1
  • Problem
  • Updated 1 week ago
I noticed that last few day we had rain and nothing registering. Wind direction and strength, temp works but rain is not registering neither on the indoor display or on the app/online. What could be wrong? 
Photo of Lars Rosell

Lars Rosell

  • 1 Post
  • 0 Reply Likes

Posted 1 week ago

  • 1
Photo of George D. Nincehelser

George D. Nincehelser

  • 6756 Posts
  • 1249 Reply Likes
Usually in this case the rain collector is either clogged with debris or something inside (like a bug nesting infestation, web, egg sacs, etc) is stopping the buckets from tipping back and forth.

Open the unit and make sure the buckets can tip freely.

Oh, one other thing... if this is a new setup, there is a short stabilzer stick that you must remove before the rain buckets can tip.  This stick is purely for holding the buckets in place during shipping and is not needed during normal operation.  Usually this stick is held in place with a piece of tape on the outside of the sensor body.
(Edited)
Photo of Marshall Toburen

Marshall Toburen

  • 2 Posts
  • 0 Reply Likes
I experienced the same problem at one point and found that ants had made a home around the water buckets.  After you clean out the bugs, place a moth ball into an open space inside the sensor.  Re-mount the sensor and spray bug spray on the post on which the sensor is located to kill / deter the bugs from climbing back up to the sensor.  That should do it!