My 01525 AccuRite Weather center is reading a -131 degrees and it is in the 50's. How do I fix it?

  • 1
  • Problem
  • Updated 1 year ago
Outside temperature is way off.  It's reading -131 degrees and it is in the 50"s here. I cleaned out the inside of the outdoor unit, but it still is not reading correctly.
Photo of Susan Storjohann

Susan Storjohann

  • 1 Post
  • 0 Reply Likes
  • puzzled

Posted 1 year ago

  • 1
Photo of Jon008

Jon008

  • 448 Posts
  • 76 Reply Likes
Did you try removing batteries, changing the A B C switch around, reinstalling batteries and checking again? This will reboot the sensor. If no change, you will need a new sensor.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Susan,

What is the model number of the sensor, and how long have you had the station for? We would recommend a hard reset to see if that resolves the problem.



  1. Bring both the sensor and display unit indoors side by side.
  2. Remove batteries from the sensor.
  3. Remove batteries from the display unit and unplug the AC adapter (if applicable).
  4. Wait 1 minute to ensure any remaining battery power is discharged from both units. 
  5. Change the A-B-C channel on both the display and sensor making sure they match.
  6. Reinstall batteries in outdoor sensor first.
  7. Reinstall batteries in display unit second.
  8. Let the units sit within a couple feet of each other for 20 minutes to ensure a wireless signal is received. 
    * The display should receive the signal within several minutes. 
  9. After a connection has been established you may place the sensor outdoors.
    *If the signal connection fails after the units are separated try a new or different location for the display unit, the sensor or both.
Photo of Kaye Gosline

Kaye Gosline

  • 2 Posts
  • 0 Reply Likes
I tried this procedure but my outdoor thermometer still says -40 and it's about 90 today.  It's back in learning mode though which I guess is a step in the right direction.
Any other advice?
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Kaye,

What is the model number of your outdoor sensor? How long have you had the weather station for? We may need to start a warranty claim.
Photo of Kaye Gosline

Kaye Gosline

  • 2 Posts
  • 0 Reply Likes
It is an 01512 that I got as a Christmas gift in 2014 I think.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Kaye,

We would recommend replacing the sensor at this time. If you run into this problem in the future there is a 1 year warranty on this product. In the new sensors we also have a replacement part available should you run into this issue instead of replacing the complete sensor.

https://www.acurite.com/5-in-1-pro-weather-sensor-temperature-humidity-rainfall-wind-speed-wind-dire... is the link to the sensor.  Please let us know if there is anything further we can assist you with.