Model 754 temps both wrong

  • 1
  • Problem
  • Updated 4 months ago
My new 754 unit is so inaccurate.  Side by side, the indoor and outdoor temps are BOTH wrong.  One reads 73, the other 66.  Our actual temp is below 60.  Is this just a poorly made device or what??
Photo of Bob Fowler

Bob Fowler

  • 1 Post
  • 0 Reply Likes

Posted 4 months ago

  • 1
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Bob,

We would recommend doing what we call a hard reset on both the display and sensor. Please follow the steps in the exact order listed. Once you have both the display and sensor powered up leave them sit together for 30 minutes without touching them. They should read within 4 degrees of each other.

You want the display and sensor to be at least 3 feet from electronics such as televisions, microwaves, computers & radios.  Follow the battery guidelines below:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

If you are following the battery guidelines perform the hard reset steps below:

1.Bring both the sensor and display unit indoors and position them side by side.

2.Remove all batteries from the sensor.

3.Remove all power from the display unit including the adapter (if applicable)

4.Wait 1 minute to ensure that any remaining battery power has discharged from both units.

5.Inside each battery compartment you'll find an A-B-C switch, change the channel to the next setting making sure they both match.

6.Reinstall batteries in outdoor sensor first.

7.Reinstall batteries (and/or connect AC adapter) in display last.

8.Let units sit within a couple feet of each other for 3 minutes to ensure a wireless signal is received.
*The display should receive the signal within several minutes.

9.After a connection has been established you may place the sensor outdoors.
 *If the signal connection fails after the units are separated try a new location for the display unit, the sensor or both.