model 06016 display not showing any rain info

  • 1
  • Problem
  • Updated 5 months ago
I have a new model 06016 display and an older 01010 display. during a recent rain event my older display registered .16 in as well as myacurite page but the new display reads 000 for current,date and total
Photo of Brian

Brian

  • 1 Post
  • 0 Reply Likes
  • confused

Posted 5 months ago

  • 1
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Brian,

Are the outdoor readings the same on both displays? We would recommend bringing both the display and sensor inside and resetting all 3 units.

You want the display and sensor to be at least 3 feet from electronics such as televisions, microwaves, computers & radios. Follow the battery guidelines below:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

Perform a hard reset:


1.Bring both the sensor and display unit indoors side by side.

2.Remove batteries from the sensor.

3.Remove batteries from the display unit and unplug the AC adapter (if applicable).

4.Wait 2 minutes to ensure any remaining battery power is discharged from both units.

5.Change the A-B-C Channel on both the display and sensor making sure they both match.

6.Reinstall batteries in outdoor sensor first.

7.Reinstall batteries in display unit second.

8.Let the units sit within a couple feet of each other for 30 minutes when comparing for accuracy
* The display should receive the signal within several minutes.

9.After a connection has been established you may place the sensor outdoors.
*If the signal connection fails after the units are separated try a new or different location for the display unit, the sensor or both.