model 02037W Humidity Stuck at 16%

  • 1
  • Problem
  • Updated 2 years ago
newly purchased model 02037W Weather Station - outdoor humidity stuck at 16%
Photo of Philip Wolters

Philip Wolters

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of George D. Nincehelser

George D. Nincehelser

  • 6747 Posts
  • 1249 Reply Likes
There are some tower sensors that don't have the humidity sensor element, and they typically will show up at 16%.

It's possible that you may have paired up with someone else's tower sensor by accident.  (They're commonly available at places like WalMart)

Try switching the A-B-C switch on both the console and the sensor to a different channel to see if that helps.
(Edited)
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Philip,

We are sorry to hear the humidity is stuck. Please make sure you are using high quality alkaline batteries such as Rayovac, Energizer, Kirkland, or Duracell. I have attached hard reset steps below: 

  1. Bring both the sensor and display unit indoors and position them side by side.
  2. Remove all batteries from the sensor.
  3. Remove all power from the display unit.
  4. Wait 1 minute to ensure that any remaining battery power has discharged from both units.
  5. Inside each battery compartment you'll find an A-B-C switch, be sure these match each other.  You may also want to try changing to a different setting.
  6. Reinstall batteries in outdoor sensor first.
  7. Reinstall batteries (and/or connect AC adapter) in display last.
  8. Let units sit within a couple feet of each other for 5 minutes to ensure a wireless signal is received.
    *The display should receive the signal within several minutes. 
  9. After a connection has been established you may place the sensor outdoors. 
If this does not correct the problem please contact us back, or contact AcuRite Customer Support at 877-221-1252. Thank you. Have a great day!