Model 00593W humidity measurement

  • 1
  • Problem
  • Updated 5 months ago
My model 00593W shows 0% humidity on the indoor sensor and 20% on the outdoor sensor.  The indoor is obviously wrong.  Actual reading should be 55%.  The outside is off by at least 30%.  The outside temperature is also off by about 5 degrees.  Indoor temperature is correct.  What's going on?  Is this fixable or should I just throw it out?
Photo of Rich

Rich

  • 1 Post
  • 0 Reply Likes
  • Frustrated

Posted 5 months ago

  • 1
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Rich,

We would recommend doing a hard reset. If that doesn't correct the issue we would recommend replacing the weather station. 

You want the display and sensor to be at least 3 feet from electronics such as televisions, microwaves, computers & radios.  Follow the battery guidelines below:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.


  1. Bring both units indoors and position side by side.
  2. Remove the batteries from the outdoor sensor only.
  3. On the indoor (display unit), where the outdoor temperature should be displayed, just above that you will see the word “OUTDOOR”. Is there a number next to it?
      a) IF YES: Press and hold the channel button on the front of the main unit until the number disappears.
      b) Press and release the channel button once, if another number appears, repeat step (a). If no number appears, continue to step (c).
      c) IF NO:
    Press and hold the channel button until you hear the main unit beep.
  4. Reinstall batteries in the outdoor sensor.
  5. Press and release the TX button inside the sensor right above the batteries. (First button on the left)
  6. The display on the main unit should now have a temperature reading from the outdoor sensor.