Lost rainfall data for the last 30 days

  • 1
  • Problem
  • Updated 1 year ago

My weather station has been working fine since my wife gave it to me Christmas (2016).  Yesterday we apparently had a very brief loss of power.  My wife said she had to reset the clock on the microwave oven, but everything else was fine.  The display still had the correct time, but the rainfall total reset to zero.  If I look back at the records it shows rainfall totals for the week beginning March 19th, but all zeros for weeks beginning 3/26, 4/2 and 4/9. 

I'm confused first as to why it reset to zero, but also because it seemed to retain information that was more than 30 days old.

I've seen a lot of comments about a "server" having problems, but I am pretty sure my weather station is completely stand-alone, so I assume all that information is stored in the display.
It's a model 01535 so I'm not even sure it has a radio clock to set the time via WWV.

Photo of Mike Steele

Mike Steele

  • 1 Post
  • 0 Reply Likes
  • frustrated and somewhat disappointed that my accumulated rain information is now lost.

Posted 1 year ago

  • 1
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Mike,

This display does run on adapter power only. It can retain the information for a couple of minutes before it will be erased after a power outage. It sounds like maybe it was in the middle of clearing the readings, and was plugged back in. Please keep an eye on it and let us know if you continue to have a problem. Thank you.