Installing my new Access hub experience

  • 1
  • Problem
  • Updated 2 weeks ago

Thought I would share my experience with the NEW Access hub.  I wanted to just install the new
hub first as a “new connection” to make sure it connected fine to the MyAcuRite  server as well as my sensors. Yeah, the picture on the instruction on installing batteries is wrong , but when you pull the battery cover open it is clearly marked and the spring end has been the negative side since the flashlight was invented, so not sure what all the fuss is about there.

Once I hooked up the cat5 cable and installed the batteries, I then plugged it in. After less than 1 minute I had a solid Blue light. I then proceeded to add it as a new “connection” device in the MyAcuRite software on PC.  Then I added my sensors one by one and all installed perfect.

Now I had both hubs running side by side and was comparing signal strength, which I am happy to report the New Access hub showed all my sensor connections as excellent signal strength compared to my old smarthub which reported fair and even poor signals.

After a day I felt it was time to replace the smarthub with the new one. At first I thought (since there are no instructions on this procedure) I would simply highlight the smart hub and click “replace” It then brings up a screen asking for the Mac address of the new hub. So I entered the address and clicked save. I then get an error stating  ”The device needs to be connected and sending data, be sure it is connected...”   I thought, well it is connected and sending data but no go. After trying this 3 times, I decided to remove the new hub from the software and unplug the new hub and remove batteries. I waited for 5 minutes and then repeated the install procedure BUT this time I did not add it as a new connection device.  Once I had a solid blue light on the Access I then tried the replace option. This time it WORKED perfect.

Now that I had the new hub in place I noticed all my sensors were connecting and updating EXCEPT the 5n1 sensor.  I waited for 15 updating. I went to Weather Underground to check the update status, same updating.  So I went in the MyAcuRite software and removed the 5n1 station and waited for it to show up as an “available sensors” I then added it again and after about 5 minutes all looked good and was updating. I had to go in and redo my “Share Weather” again and add the 5n1 sensor again and off it went. I am now a happy camper and all is working well.

AcuRite should have a sticky posted or a FAQ on how to replace the hub. This would save a lot of confusion and people calling tech support. 
Photo of Stick


  • 27 Posts
  • 10 Reply Likes

Posted 3 weeks ago

  • 1
Photo of H Hord

H Hord

  • 2 Posts
  • 1 Reply Like
I installed my new Access yesterday and the process was as simple as can be. 

My signal strength is 4 bars/excellent from all devices (5 in 1 and six temp & humidity sensors scattered around the house on all levels).  Signal strenth was poor with the Smart Hub. 

When I hooked up the Access hub the blue light stopped blinking in a minute or two, but I still decided to wait 30 minutes before taking any further action.

I wanted to talk to AcuRite before I started the process, I was 22nd in line so I left my number and got a call from them in about 30 minutes--GREAT SUPPORT
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 5522 Posts
  • 179 Reply Likes
Hello Stick and H Hord,
Thank you for taking time to write and share your experience. We are happy to hear you are up and running. Your feedback will certainly help us continue to improve and provide the best troubleshooting possible to our customers. Please let us know if you have any other questions. Thank you.