I'm Done With AcuRite

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Done with AcuRite. I've had my 5 in 1 for 2 years. The sensor shows only -40 for outside temp  data. I tried multiple hard resets and changing batteries in both units to no effect. Yesterday I tried calling AcuRite technical support. A recorded message told me I was 21st in line but I was given the option to be called back without losing my place in line. I took that option. A day and a half later and I have received no call back. I should have suspected bad service when the message said 21 people were already waiting for service ahead of me. From what I've read here on the AcuRite Community if if the hard restart doesn't work I'm probably in need of a new sensor. I have another idea. Stop investing in a company that doesn't respect its customers enough to honor a call back and whose products don't last 2 years in the field. I've taken all my AcuRite stuff and dumped it into the recycle bin. I'm done with AcuRite. I'll be sharing this experience at all applicable websites that involve AcuRite products.
Photo of John Mandeville

John Mandeville

  • 3 Posts
  • 1 Reply Like

Posted 3 months ago

  • 1
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello John,

We are sorry you were not able to reach us.  We have had a higher than normal call volume. We are sorry to hear you threw the weather station away. If you are able to get it out of the recycle bin we would be happy to go through steps with you on here, and assist you with your product.
Photo of Steve James

Steve James

  • 14 Posts
  • 3 Reply Likes
Same problem here John.. The Temp Sensor needs replacing. They are out of stock. Have posted , but no,  reply. Mine lasted 15 months. No idea when they will be in. Seems to be a common problem with this weather station. It is not much use now. 
Steve.
Photo of Jon008

Jon008

  • 415 Posts
  • 72 Reply Likes
Take it out of the trash, and open it up. (5 in 1) You will want to inspect the air sensor down under the black cover, (take it off) then pull out the air sensor board just over the air vent. Check for corrosion of the board leads, and corrosion of the very tiny metal lines coming off the black square which is what reads humidity etc. DO NOT touch this, but with a very small poker, clean around the sides of it by carefully scraping off the metal.
Photo of Steve James

Steve James

  • 14 Posts
  • 3 Reply Likes
Hi. Just given that a go. No luck . Still reading - 40 deg & 1 percent  hum. Thanks for trying.
Steve.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6162 Posts
  • 195 Reply Likes
Hello Steve,
We have emailed you at the email address associated with your community forum account. The temperature and humidity board is due back in stock 3/2/18. We are happy to assist you with your station. Please let mw know if you have any questions. Thank you
Photo of Steve James

Steve James

  • 14 Posts
  • 3 Reply Likes
Hi .Thanks for that. I live in the UK , so can it be shipped to there. I will pay what ever it costs if you could let me know. Seems a same to bin it , just because of  this part is not working. Thanks.
Steve.
Photo of Steve James

Steve James

  • 14 Posts
  • 3 Reply Likes
Hi. Rachell. So there is no support for AcuRite  products at all in the UK if they
go wrong. Thanks for letting me know. That was a lot of money to pay for a 
 weather station, that lasted , just over a year. Not very good is it. 
Steve.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6162 Posts
  • 195 Reply Likes
Hello Steve,

We do provide warranty coverage in the areas where we sell our product. I am happy I was able to assist you via email with this issue. Please let us know if you have any other questions. Thank you.
Photo of Steve James

Steve James

  • 14 Posts
  • 3 Reply Likes
So you do ship parts to the UK now. I thought it was only USA & Canada. Thanks for sorting out the part for my weather station. This was bought in the UK. 
Steve.
Photo of Roy Griffith

Roy Griffith

  • 54 Posts
  • 5 Reply Likes
Steve if you can tell which lead on the board (assuming it is only one) and you are somewhat proficient at soldering you can solder a jumper by passing the lead. I did this and was able to get another year our of my five in one. Then another two leads got corroded and now my 5 in 1 doesn't work at all.  Might order a replacement sensor and try to install it myself.
Photo of Steve James

Steve James

  • 14 Posts
  • 3 Reply Likes
Hi Roy. I have just put in a replacement sensor & it is all up & 
running again. Worth the $9.99 out lay. Should last another year. 
Steve