I have Model 01036, the indoor unit shows 74 degrees (wrong), and 74 for a high and low (wrong) . I see no indication that i need batteries

  • 1
  • Problem
  • Updated 1 week ago
I have model 01036,the indoor unit says 74 degrees outside (wrong) and the high and low also say 74 degrees (wrong). They don't answer the phone. Or else leave your number but no one calls. No indication I need batteries. Somebody help. !!!
Photo of Ruthi

Ruthi

  • 5 Posts
  • 0 Reply Likes
  • very disgusted with his product !!!

Posted 3 weeks ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 5903 Posts
  • 189 Reply Likes
Hello Ruthi,
If your weather station is reading inaccuracies, please verify you are using the battery recommendations and try the troubleshooting steps listed below. Please let us know if the issue continues. Thank you.

Batteries:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4°F/-20°C) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

Hard reset:
- Bring both units side by side and remove all batteries, unplug display if it has an ac adapter
- Change the ABC Switch to a different setting and ensure that both are on the same setting. example - If on A, move both to C
- Place batteries into the outdoor sensor first
- Place batteries into display
- Allow units to sit side by side until they connect.
Photo of Ruthi Mayer Mazur

Ruthi Mayer Mazur

  • 1 Post
  • 0 Reply Likes
Thank you for responding, Rachell.  This is really strange as in the last week the units are working perfectly.  I do have/had new Lithium batteries in the units. I will keep your information but at this point I'm not going to change anything. If the problem develops again, I will follow your instructions.
Thanks again,  Ruth Mazur
P.S. The unit is only 2 years old.