I have a brand new unit. No back light. Either with or without batteries. When you press and hold the light button it beeps bit no light.

  • 1
  • Question
  • Updated 7 months ago
I have a brand new unit. No back light at all. Either with or without batteries. When you press and hold the light button it beeps bit no light.
Photo of Dawn Benn

Dawn Benn

  • 5 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Dan

Dan

  • 53 Posts
  • 15 Reply Likes
You need to provide more info then just "unit".. what's the product and model number?
Photo of Dawn Benn

Dawn Benn

  • 5 Posts
  • 0 Reply Likes
Sure.model 01022, 02080, 06046 weather station w l8ghtning sensor. Sensor 06045. 5 1 weather sensor 060044
Photo of Dan

Dan

  • 53 Posts
  • 15 Reply Likes

If this is your display?https://www.acurite.com/color-display-lightning-weather-station-06046m.html manual says holding it for 5 seconds disables the light.

 

"Display Backlight Settings This weather station’s color display features three different lighting settings: High (100%) brightness, Medium (60%) brightness and Low (15%) brightness. Using battery power alone, the backlight is available momentarily for 10 seconds by pressing the “LIGHT” button. When the display is powered with the power adapter, the backlight remains on at 100% brightness. Press the “LIGHT” button once to dim to 60% brightness; press again to dim to 15%, press a 3rd time to enter “AUTO DIM” mode. “LIGHT” will appear next to the clock.

 NOTE: Pressing and holding the “LIGHT” button for 5 seconds will disable the backlight. Once any button is pressed, the backlight will return to your selected setting."

(Edited)
Photo of Dawn Benn

Dawn Benn

  • 5 Posts
  • 0 Reply Likes
That is it. It has no light at all, ever. Thought maybe there was a clue I was missing.
Photo of Dan

Dan

  • 53 Posts
  • 15 Reply Likes

It may be defective then if it never did work outa the box?

support will read your thread here tomorrow if there's still a problem they will issue a replacement. 

Photo of Dawn Benn

Dawn Benn

  • 5 Posts
  • 0 Reply Likes
Right out of the box no light. Looks like sensors work just not the main unit. Surprised as it's packed really well. And I have a smaller older unit with no issues. Thanks for the reply!
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Hello Dawn,

Do you see numbers on the display unit?  Is only the backlight not turning on?  If you are receiving signal from your sensors but not a backlight, please verify you are using the battery recommendations and try the troubleshooting steps listed below. Please let us know if the issue continues. Thank you.

Batteries:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4°F/-20°C) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.




To do a pinhole reset: (THIS WILL CLEAR ALL OF YOUR HISTORY AND YOUR SETTINGS)

Please verify that you are using a name brand (Rayovac or Energizer) standard alkaline batteries in the display unit. We do not recommend using anything that is heavy duty, rechargeable, store brand or Lithium inside of the display.

- Remove all power, AC adapter and batteries from the display unit.
- Press and hold down the pin hole reset button, located in the battery compartment, for 20 seconds.
- Plug back into AC power and insert recommended batteries.
- Press and hold down the pin hole reset button for an additional 20 seconds.
- Verify that the unit has powered on and once connection has been made, attempt to set time and date.
Photo of Dawn Benn

Dawn Benn

  • 5 Posts
  • 0 Reply Likes
Had to send the unit back. No lights at all. Thank you and my new unit is here so let's hope this one is hood to go
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Dawn,

Please let us know if there is anything we can assist you with. We are sorry to hear this happened.
Photo of Dan

Dan

  • 53 Posts
  • 15 Reply Likes
Contact support see what they say.