dual color displays are showing different outdoor temperatures and humidity. As much as a 5 degree F difference

  • 1
  • Problem
  • Updated 1 year ago
I just received my 5-in-1 weather station with dual displays. My two displays are showing different outdoor temperatures and humidity. As much as a 5 degree F difference in temperature.  Since I have only one 5-in-1 weather stations I would expect both displays to show the same outdoor temperature
Photo of Keith Roskelley

Keith Roskelley

  • 2 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of Michael B

Michael B

  • 401 Posts
  • 101 Reply Likes
Maybe someone close to you has a Acurite product and your picking up there signal . What I would try is changing the channels on all 3 items to a new one . Make sure that you change all three pieces to the same new channel  !!!
Photo of Steve U

Steve U

  • 490 Posts
  • 62 Reply Likes
I second Michael B's suggestion.
I can see my neighbors  5 in 1 on MyAcurite dashboard. In an urban setting, this type of occurrence would be common .
Photo of Keith Roskelley

Keith Roskelley

  • 2 Posts
  • 0 Reply Likes
It does not appear to be the channel.  I changed all three devices to channel B.  When I woke up this morning one display read outside temperature of 59 and the other said 73.  Local news says airport is 56.  I moved the two display to the same location and the one display still reads 73
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Keith,

Do you have 4 bars on both of the displays?  Please try the steps below for all 3 units.

1.Bring both the sensor and display unit indoors side by side.

2.Remove batteries from the sensor.

3.Remove batteries from the display unit and unplug the AC adapter (if applicable).

4.Wait 1 minute to ensure any remaining battery power is discharged from both units.

5.Change the A-B-C Channel on both the display and sensor making sure they both match.

6.Reinstall batteries in outdoor sensor first.

7.Reinstall batteries in display unit second.

8.Let the units sit within a couple feet of each other for 20 minutes to ensure a wireless signal is received.
* The display should receive the signal within several minutes.

9.After a connection has been established you may place the sensor outdoors.
*If the signal connection fails after the units are separated try a new or different location for the display unit, the sensor or both.