Display sleep does not work with PC Connect running

  • 1
  • Problem
  • Updated 6 months ago
I have my "Energy Saver Settings" set to never sleep the computer but to sleep the display after 1 minute.  This has always worked fine for me but with PC Connect running the display never sleeps.
Photo of Robert

Robert

  • 9 Posts
  • 5 Reply Likes

Posted 2 years ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6428 Posts
  • 200 Reply Likes
Hello Robert,

Letting the monitor sleep can be disconnecting the internet service.  We would recommend changing this setting to not let your monitor sleep.  Please let us know if you have any other questions.  Thank you and have a great day!
Photo of Alexus Sheppard

Alexus Sheppard

  • 5 Posts
  • 3 Reply Likes
Letting the monitor sleep does NOT disconnect the Internet service of the computer. How can I bypass that setting and let the monitor sleep?
Photo of Robert

Robert

  • 9 Posts
  • 5 Reply Likes
Alexus --- I agree, the display sleep is different from sleeping the computer (in my case a MacBook Air).  I have given up on the program and only run it to download data once a week or so.  I also have had my computer freeze several times when PC Connect for the Mac is running.  Hopefully they will address these problems someday with an update.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Alexus & Robert,

If there is a setting on your computer that when your computer goes to sleep it disconnects from the internet it will stop transmitting online. There is a box to check on the software that says prevent this PC from going to sleep.  Thank you. Enjoy your day!
Photo of Kerwin

Kerwin

  • 16 Posts
  • 0 Reply Likes
All settings are correct on my computer yet display sleep does not happen while PC Connect is running. I removed all instances of anything to do with AcuRite software restarted my computer, downloaded a fresh copy and am now using it. The same issue with the checkbox continues to happen. Here is a screen capture showing I uncheck it, use the menubar icon to hide and then display the app and as you can see, the checkbox is back on.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Kerwin,

Thank you for the video. I have let our development team know about the issue, and will look into it.  As of right now I do not have a time frame as to when this will be corrected. Thank you for providing us with this information.  
Photo of David Black

David Black

  • 1 Post
  • 0 Reply Likes
I am having the exact same thing happen to me as Kerwin. We've run Acurite's software on 3 Apple computers (2 iMacs and a MacBookPro) and the scenario is identical:  Regardless of whether we have the 'prevent computer from going into sleep mode' box checked or unchecked, the display stays on. Period. If we shut the Acurite app down (and don't touch anything else), then the displays go to sleep just as they're supposed to. The OS versions on these computers are not the same, so we find it hard to believe it's an issue with Apple's OS; rather, Acurite's app, being the only thing in common, is where we think the issue lies. This is a shame, because we really like to access the app on other devices (as well as feed data to Wx Underground), neither of which we can do when we have the shut down, so it really limits the usefulness of the whole system. We're very anxious to see a fix for this. Thanks!
Photo of Jack Canavera

Jack Canavera

  • 402 Posts
  • 98 Reply Likes
Unless things have changed I found that "prevent computer from going to sleep" does not keep the Mac awake.  The only way I found to keep the Mac from sleeping was to go to System Preferences and go to Energy Saver.  From there you can control the sleeping attributes of your Mac.  It's been a while and I was using an iMac at the time so I know for sure I had to set Computer Sleep to Never.  I'm not sure whether I had to set Display to never also.  It may vary as to whether you use an iMac or a laptop.

I did report that as a bug quite a few months ago.  
(Edited)
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello All,

We are aware of the issue, and our development team is looking into it. As of right now we do not have a timeframe of when this will be corrected. Please go into your settings and adjust them to make sure your computer does not go to sleep. Thank you.
Photo of Fairley Cope

Fairley Cope

  • 22 Posts
  • 2 Reply Likes
I have Windows 10, on an HP laptop, that works 24/ 7. The screen goes black at around 10 minutes (set in display settings). The PC Connect continues to work. I also have (screen saver) set to 'none'. Try setting your display time to 5 to 15 minutes, and turn off screen saver. I never had to (check) the box in PC Connect to keep the computer from going to sleep. I don't know if this has something to do with the data time interval, that PC Connect needs to send data out. The laptop lid is always open,for better ventilation. If all else fails, runs some small app in the background, to keep computer awake. Good luck.
Photo of David Denowh

David Denowh

  • 2 Posts
  • 1 Reply Like
I am very surprised to see that this issue where the Acurite PC Connect for the Macintosh interferes with the display (not computer) sleep as well as preventing the screen savers from working has not been addressed on over a year? Seriously just remove the code from your software that hooks into the system sleep controls already. You are selling a very expensive weather station that works really well and now we as customers are forced to put extra wear and tear on our MUCH more expensive computer systems? Please fix this. You can do this in a software release immediately. Thank you.
Photo of dbinbama

dbinbama

  • 4 Posts
  • 0 Reply Likes
When Acurite's software was never fixed several months after the problem had been discussed last summer, I figured out that it probably wasn't a priority to them, and I didn't need to hold my breath, waiting. In the meantime, I learned about UnderTheWx (Weathercloud.net) for Mac and I installed it. There have been a hand full of glitches with UnderTheWx for me, but overall, it has worked well (and no displays staying on all the time). Easy to connect into WeatherUnderground, I just pull up my station from their page to look at my data. I don't even use Acurite's software anymore. That might be a solution for you, too.
Photo of David Denowh

David Denowh

  • 2 Posts
  • 1 Reply Like
Wonderful! Thank you, I will take a look at UnderTheWx.
Photo of keith

keith

  • 25 Posts
  • 1 Reply Like
This monitor not sleeping is only one of several pains in the butt with the program. Mine won't stay connected to the display unit and/or will stop sending to WU or to MyAcurite.  This is the same problem as with the windoz version of the software...but the display will sleep with it.
With my Davis VantagePro2 I use WeatherCat and there simply are not any problems with it..period..never.  Of course that software is expensive but that is not an excuse for AcuRite to create sorry software.
keith
Photo of Kerwin

Kerwin

  • 16 Posts
  • 0 Reply Likes
My feelings about not only the software but, the hardware itself, I find it to be very amateur compared to others and should be sold in toy stores. None of the problems have been addressed.

I’ve been using UndertheWX for a while now. It isn’t perfect but, it does a much better job. I query its data table every minute as it gets updated several times per minute and stores it in an SQLite database file. I can use this data as I like, currently on a webpage. It doesn’t capture all data and each record doesn’t capture all readings at once but, is a major improvement over the Acurite software.
(Edited)