Can't register Accu-link bridge

  • 3
  • Problem
  • Updated 2 years ago
I just got an AcuRite 09150 AcuLink Internet Bridge and I have not been able to register it. I've tried 4 times. I've verified that the MAC address is correct, I've pressed the register button for 5 seconds, I've power cycled it, not sure what else to try. I can ping the device locally, both lights are flashing. Let me know what else to try or how I can troubleshoot this.
Photo of Larry Martell

Larry Martell

  • 2 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 3
Photo of George D. Nincehelser

George D. Nincehelser

  • 6739 Posts
  • 1248 Reply Likes
Try opening a web browser to the bridge's IP address and look at the diagnostic page.  It should show things like the sensors it can currently "hear" and the versions of the boot and app code.

It will also show the MAC, which should match what is physically marked on  your bridge.

If you want, you could post that page here for us to look at, but please obscure the last half of the MAC address.  You want to keep that info private between you and Acurite.
Photo of Larry Martell

Larry Martell

  • 2 Posts
  • 0 Reply Likes
MAC matched, and it can see my sensor. 
Photo of George D. Nincehelser

George D. Nincehelser

  • 6739 Posts
  • 1248 Reply Likes
That all looks good.  I suggest you hold tight until you hear from an Acurite employee.

Most likely Acurite will have to force the  registration on their end.  I'm not sure why that happens so often, but they should be able to fix you up.  

They'll likely be sending you an email about it so you can transfer sensitive account info in private.  If you haven't already, registering your product so they will have your email address will speed things along.

http://www.acurite.com/product-registration
Photo of AcuRite Crystal

AcuRite Crystal

  • 2000 Posts
  • 111 Reply Likes
Hi Larry,

We see that you called in to do the force registration of you mac address.  If you have any other questions, please feel free to let us know.
Photo of Bogdan Alexandru Rusu

Bogdan Alexandru Rusu

  • 2 Posts
  • 0 Reply Likes
Hi,
I have same problem, I can't register my unit.
could you please help me?
thank you.

(Edited)
Photo of Bogdan Alexandru Rusu

Bogdan Alexandru Rusu

  • 2 Posts
  • 0 Reply Likes
Hi,
I called support and they helped me, now it's working.
thank you.