Can't Re-Add Smart Hub after Replacing It with New Access

  • 2
  • Question
  • Updated 6 months ago
I just replaced my smart hub with the new Access. Now I'm trying add back the Smart Hub and a new device so I can use both. When I try, I get this message...

"
  • Device must be connected and reporting data to claim it. Please make sure the device is connected to your router and the status lights are blinking."
I've tried unplugging both the power and network cables and still nothing.

How can I get it to work?
Photo of Edward Ward

Edward Ward

  • 102 Posts
  • 14 Reply Likes

Posted 7 months ago

  • 2
Photo of Edward Ward

Edward Ward

  • 102 Posts
  • 14 Reply Likes
Still trying...

Amber light in back ~ Flashing
Green light in back ~ Solid
Blue network light on left~ Flashes about 1 per second
Blue sensor light on right ~ Solid

I've tried pressing the activation button
Holding the activation button down for 4 seconds
Holding the activation button down for 15 seconds
Holding the activation button down for 30 seconds

If I unplug the network cable for a few minutes, the network light goes off. Then I plug it back in, it goes back to blinking.

So it seems to be working fine, just can't add it to my account.

What else can I try?
Photo of Steve U

Steve U

  • 490 Posts
  • 62 Reply Likes
My Access just showed up in todays mail.   Here is what I did to transfer WU (sensors can remain on your old one)
(assumes you have spare network ports available)
Plug the cables as outlined in the quick start guide. Wait (many minutes) for the blue light to be steady.
Open My Acurite,  Add the discovered Access.
Add sensors (this is the PITA part if you have a bunch.)  Naming them. (edit sensor)
Once that is done and things look good on the DASHBOARD
Wunderground part
Select SHARE WEATHER under settings.  REMOVE the tick next to the smarthub and TICK the Access
EDIT the Wunderground sharing Fill in your  password and then select the Access (was the smarthub)

Exit  That is it.  Your old WU settings (under the smarthub) do not need to be removed because you are not sharing your smarthub, so they get ignored.

WU graphs never even saw the transition smarthub->Access
Photo of John Kauai

John Kauai

  • 46 Posts
  • 1 Reply Like
FWIW: I had to edit the "Sharing to Wunderground" dialogue and specifically remove the smartHUB before the change worked when I added the Access.  Without the change, I was told the Station ID was already being used (by the smartHUB) 

I especially like that the access has MUCH better reception than the smartHUB.  My 4 sensors all report a signal strength of 4 vs 1.  I get this information by pointing my web browser to the IP address that has been assigned to the Access by my local router using DHCP.  Getting this IP address is not easy since you have to understand the ARP protocol and how to read the information.

It does appear that wunderground does not notice the change in source.

I did not see any "Replace Function" options.
Photo of Edward Ward

Edward Ward

  • 102 Posts
  • 14 Reply Likes
I just used the Replace function. That transfered all my sensors from the Smart Hub to the Access. I just had to redo the underground part.

Anyway...

Today I was able to add the Smart Hub back on, no problem at all.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Hello Edward,
We are sorry for any inconvenience experienced. We are happy to hear you are back up and running. Please let us know if you have any questions. Thank you.
Photo of HeloMech

HeloMech

  • 79 Posts
  • 17 Reply Likes
I got by access to log in yesterday and I'm having the same problem how did you get your smart hub connected?
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello HeloMech,

When you go to add your smartHUB are you getting an error message? What are the lights doing on the smartHUB? Make sure you have DHCP enabled, and Mac address filtering disabled.  Make sure you have TCP Port 80 open as this is the port the smartHUB sends information through.
Photo of John Kauai

John Kauai

  • 46 Posts
  • 1 Reply Like
FWIW: if you have an Access, I cannot imagine any reason you would want the smartHub to still be sending data.  I did do this for a period of time, but because the smartHub has a poor wireless performance with the system it collects data from, I continued to get warnings from both Acurite and wunderground that those systems were dropping off-line, and if the power to my cable company went down (can you imagine that?) warnings of lost data.  So, I discontinued the smartHub.  (In case it isn't clear, "MyAccurite" did show both the Access and smartHub as options but only one was reported to wunderground.  The information displayed was more or less the same so it isn't like there is any advantage to having both -- unless you allocate a different set of sensors, but I cannot imagine any advantage in doing that.)

Given that....

I have found that the Smart Hub does not respond to ARP requests all the time.  In fact, it seems to send out broadcast ARPs that may claim an IP address that is already allocated via DHCP to a different host on your network.  My router ignored those ARPs which meant that the smartHub could not talk on my network at all.  If you have a sniffer application that you can use, and if you have a "smart bridge" (TP-Link makes one that is really cheap) that can be configured to send all packets that traverse the bridge to a listening port, then you can monitor this same thing.  NOTE: it has to be a bridge and not a router.  The apple airport, for example, will not allow you to "snoop" all the packets, only the packets that are routed through the port a given device is connected to.

What you might do is try to discover the IP address that the router has provided to your smartHub.  Unfortunately, the Apple Airport no longer shows you the MAC addresses it hands out to systems connected to the ethernet port.  If you have a "terminal" application that can directly access the ARP table then with a little detective work you can figure it out.

I use Emacs but that is because I've had years of experience with it as an extremely powerful text editor, mail application, shell application and so many other functions.  I rarely use it now though.

Here's what the arp table looks like on my Mac.  (being a newer mac it no longer has an ethernet port only the wireless port).  Note the 10.0.1.39 address has a MAC address that starts 24;c8:6e: this is assigned to Accurite.  Given that information, I can use my browser to go to 10.0.1.39 which returns a page that provides some raw data about my Access.  

The problem everyone is seeing is that ARP entries can take a very, very long time to be removed.  You might think that rebooting your DHCP router would solve the problem, and sometimes it does, but some routers remember who it had assigned IP addresses to through the reboot, and if your smartHub or Access didn't have one before the reboot, it may not get a new one after.

DHCP is a complicated protocol and sometimes it just doesn't work.  When you have an ARP implementation (ala the smartHub) on top of that that doesn't follow -all- of the rules then things get really messed up.  All you can do is wait.  Sadly, sometimes trying to take active steps just messes things up more because it restarts the ARP timeout.

bash-3.2$ arp -an? (10.0.1.1) at 90:72:40:c:8c:9f on en0 ifscope [ethernet]
? (10.0.1.2) at 0:26:b0:e9:c5:14 on en0 ifscope [ethernet]
? (10.0.1.3) at 84:ba:3b:85:14:2d on en0 ifscope [ethernet]
? (10.0.1.4) at a4:5e:60:d6:83:73 on en0 ifscope permanent [ethernet]
? (10.0.1.36) at 0:11:24:e:d:7b on en0 ifscope [ethernet]
? (10.0.1.37) at 90:72:40:c:8c:9f on en0 ifscope [ethernet]
? (10.0.1.38) at 68:a8:6d:5c:40:20 on en0 ifscope [ethernet]
? (10.0.1.39) at 24:c8:6e:a:50:2f on en0 ifscope [ethernet]
? (169.254.138.165) at 68:a8:6d:5c:40:20 on en0 [ethernet]
? (224.0.0.1) at 1:0:5e:0:0:1 on en0 ifscope permanent [ethernet]
? (224.0.0.251) at 1:0:5e:0:0:fb on en0 ifscope permanent [ethernet]
? (225.255.255.255) at 1:0:5e:7f:ff:ff on en0 ifscope permanent [ethernet]
? (239.255.255.250) at 1:0:5e:7f:ff:fa on en0 ifscope permanent [ethernet]
? (255.255.255.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]
bash-3.2$