AcuRite model 02099 started beeping and pressing reset button for 20 seconds has not returned unit to normal connection

  • 1
  • Problem
  • Updated 5 months ago
Unit was purchased 5 weeks ago and started beeping suddenly.  No alarms had been set and no items showed on the screen during the beeping.  Batteries were checked in both indoor and outdoor unit  (all good and all alkaline) and reset was pressed and held for 20 seconds.  Nothing has worked to return the unit to normal operation.  If a solution is not found soon, I am looking at returning the product to the store for refund.
Photo of Glen MacDonald

Glen MacDonald

  • 6 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Bill Martin

Bill Martin

  • 742 Posts
  • 125 Reply Likes
remove batteries/AC adapter for 5 mins and then re apply power. see if this resets and beepimg condition doesn't come back
Photo of Glen MacDonald

Glen MacDonald

  • 6 Posts
  • 0 Reply Likes
Thank-you.  That brought a normal screen back although after allowing several hours of calibration, numbers for the outside temp would not display properly so I did another 20 second reset and so far the display is normal and operation seems normal.
Photo of Bill Martin

Bill Martin

  • 742 Posts
  • 125 Reply Likes
Glen: if it happens again, try to remember the conditions and send to Acurite. The more data the better for them to replicate and diagnose root cause.
Photo of Glen MacDonald

Glen MacDonald

  • 6 Posts
  • 0 Reply Likes
Yes.  Thanks again.  Here's hoping it doesn't happen again.  I was fairly impressed with the unit when we purchased it.
Photo of Glen MacDonald

Glen MacDonald

  • 6 Posts
  • 0 Reply Likes
The unit again last evening starting beeping and the screen characters became jumbled.  I am planning to return the unit to the store and replacing it with a new 02099 and praying that the new one does not have the same flaw.

new
Photo of Bill Martin

Bill Martin

  • 740 Posts
  • 125 Reply Likes
smart call. too frequent....
Photo of Glen MacDonald

Glen MacDonald

  • 6 Posts
  • 0 Reply Likes
Once again - I should note that no alarms had been set.  Alkaline batteries were good on both the remote and main units.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Glen,

We are sorry to hear this happened. Thank you for letting us know about this. Did you return the non functioning display to the store or do you still have it? We do have a 1 year warranty on our product, and would be happy to go through the troubleshooting steps with you. If we are not able to get it corrected we can initiate the warranty process. Thank you.
Photo of Glen MacDonald

Glen MacDonald

  • 6 Posts
  • 0 Reply Likes
I was sorry too.  Yes it was returned to the store and while I was prepared to purchase a new and identical unit on the assumption that the flawed unit was a lemon and another model would be ok, the store had no stock.  I have now ordered a different unit by another manufacturer which is similar in the environmental factors measured and displayed and I'm hoping for better luck.  I was happy to have some assistance from another member of the community support area but I must say I was surprised that company assistance was challenging to obtain - at least in a timely way.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Glen,

We are sorry to hear that. We do try to respond to the posts on a daily basis. Please let us know if there is anything further we can assist you with now or in the future.