acurite model 00554sbdi only has 15% and 60% brightness

  • 1
  • Problem
  • Updated 1 month ago
acurite model 00554sbdi only has 15% and 60% brightness
Photo of Charles Stabler

Charles Stabler

  • 3 Posts
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6284 Posts
  • 199 Reply Likes
Hello Charles,

What brand of batteries are you using? Please verify you are using the battery recommendations listed below. If you are, try removing the battery for a full two minutes to let the display power down completely then reinstall the battery.  If the backlight still does not show three different settings, please let us know. Thank you.

Batteries:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4°F/-20°C) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.
Photo of Charles Stabler

Charles Stabler

  • 3 Posts
  • 0 Reply Likes

Batteries are new and it is plugged in to power adaptor, that came with it. 


Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6284 Posts
  • 199 Reply Likes
Hello Charles,
Did you try the troubleshooting suggested above? What brand of batteries are in the unit? When and where was this purchased? Thank you.
Photo of Charles Stabler

Charles Stabler

  • 3 Posts
  • 0 Reply Likes

Yes I did and new Duracell batteries.  I believe the high setting led is bad.