Accurite 7507A3 not reading remote sensor

  • 1
  • Problem
  • Updated 1 year ago
My Accurite 7507A3 stopped reading the temp from the outside sensor, it was permanently at 78 degrees (outdoor sensor itself had the correct temp, the base station just always said 78). I tried replacing the batteries in case they were dying, but now it just shows --- for the outdoor temp on the base station. 
I've gone through all the troubleshooting, replaced batteries in both units, pressing the "signal" button on the base station and reset button on outdoor sensor but no change. All the troubleshooting I read say to make sure the A/B/C switch is in the same position on both sensors but the outdoor one does not have a switch.
The signal tower bar is flashing on the base station with no bars  When I first but batteries in the outdoor sensor, the light flashes red briefly then goes off. The signal symbol on the outdoor sensor is full.
What else can I do to get this to work again?
Photo of me10lee83

me10lee83

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 1 year ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Hello me10lee83,
Tom is correct, this unit is not compatible with any other sensor besides the 00592 that has the ABC switch inside the unit.  Do you have any other AcuRite products?  Thank you. 
Photo of me10lee83

me10lee83

  • 6 Posts
  • 0 Reply Likes
I don't have any other acurite products so no idea where I would have gotten this other sensor from other than with the original product... also it worked fine until maybe the last few months when the base station would read a constant 78 degrees regardless of the temp displayed on the outside one
this is what mine looks like (and the main sensor too just to be sure we're talking about the same one
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello me10lee83,

Does it give a name brand on the sensor you are using? Is there a model number on the sensor?
Photo of me10lee83

me10lee83

  • 6 Posts
  • 0 Reply Likes
Nope, just the little round sticker that looks like it's prob just info from the factory where it was made or checked. No info at all otherwise
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello me10lee83,

I did confirm this is not one our sensors. I thought possibly it was an older sensor before my time with the company, however it is not. We have posted a link below in the thread with the correct sensor for your display. Thank you.
Photo of me10lee83

me10lee83

  • 6 Posts
  • 0 Reply Likes
Is there a way to order another outdoor sensor since I don't have the right one somehow, so I don't have to buy a whole new set?
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello me10lee83,

The link below has the correct sensor for your specific model. Thank you.

https://www.acurite.com/temperature-and-humidity-sensor-06002rm-592txr.html
Photo of me10lee83

me10lee83

  • 6 Posts
  • 0 Reply Likes
What is the exact model number of the sensor I need? The website lists several different model numbers
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello me10lee83,

I attached the link in the response above for the specific sensor you would need. It is the 592TXR/06002RM sensor. If you click on that link it will take you directly to the sensor that is compatible with your weather station.