827RX

  • 1
  • Problem
  • Updated 2 years ago
I have a 827RX  unit that is reading 158 for the outdoor temp.  I don't think mine has a heat-index feature.  How do I reset it to regular outdoor temps?  I have removed the batteries and reinstalled them in the correct order to no avail.
Photo of Carmen Ganter

Carmen Ganter

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Good morning Carmen,

I have added some troubleshooting steps below.  If these directions do not correct the issue, please contact AcuRite Customer Support at 877-221-1252.  Thank you and have a great day!

Batteries:
•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.
•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.
•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.
•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.
•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.
•Mixing different battery types (brands, old/new, etc.) is not recommended.

Hard reset:
- Bring both units side by side and remove all batteries, unplug display if it has an ac adapter
- Place batteries into the outdoor sensor first
- Place batteries into display
- Allow units to sit side by side until they connect.
(Edited)