754w5 switchs uncommanded to c° & reports wrong temp at that.

  • 1
  • Question
  • Updated 10 months ago
Photo of Lloyd G Huitt

Lloyd G Huitt

  • 1 Post
  • 0 Reply Likes
  • screwed

Posted 10 months ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6428 Posts
  • 200 Reply Likes
Hello Lloyd,

The accuracy rating is +/-2° and 5% per unit. Please verify you are using the battery recommendations and try the troubleshooting steps listed below.  Please let us know if this does not correct the issue. When and where was the unit purchased?  Thank you. 



Batteries:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4oF/-20oC) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

Hard reset:



- Bring both units side by side and remove all batteries, unplug display if it has an ac adapter



- Change the ABC Switch to a different setting and ensure that both are on the same setting. example - If on A, move both to C



- Place batteries into the outdoor sensor first



- Place batteries into display



- Allow units to sit side by side until they connect.



(Edited)