75127A1 Clock Temperature Sensor Defective

  • 1
  • Problem
  • Updated 4 months ago
The indoor temperature sensor on my clock seems to be off by 4-5 degrees Fahrenheit at any given time. For comparison, I'm using a Fluke multimeter that came back last week from UL calibration/certification. I've tried resetting it (removed adapter and batteries for an hour), moving the clock to a different spot on the wall, standing it upright on my desk, moving the power adapter to another outlet, and tried new Duracell Alkaline and Energizer Lithium batteries (although this shouldn't be relevant). 

I work in electronics manufacturing (temperature/pressure/humidity/current sensors and level controls) so I get it, not every unit is a winner. As there is no way for me to calibrate the temperature sensor, I'm only left with the option to file a warranty claim for the device. Is there a way to file the claim online rather than by phone? I'm not seeing an email address listed anywhere on the support page. 
Photo of Mat L

Mat L

  • 2 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6284 Posts
  • 199 Reply Likes
Hello Mat L.,
AcuRite’s accuracy standard for weather products is +/-2°F. When comparing two AcuRite thermometers, there may be up to a 4° difference in temperature. Example: Current temperature is 70°F. Unit 1 reads 72°F (+2°) and unit 2 reads 68°F (-2°F). Can you please provide a picture of the unit side by side for warranty?  Thank you.