5 in 1 Weather Station connected to PC with USB showing incorrect rain total on myacurite app

  • 2
  • Problem
  • Updated 1 year ago
My weather station is connected to my PC with the USB. Myacurite app is showing incorrect totals.The app totals are way higher than the rain recorded on the weather station. For example rain totals for the last 3 days is 35.81mm and myacurite is showing 48mm. Have only had it for a week and am very disappointed, I was hoping to rely on the app for rain totals while I am away so I can water gardens remotely. I have ordered the smartHUB so I don't need to leave the unit plugged in to my PC but am wondering now if I have wasted money on a product that is unreliable. Hoping you can fix this issue   
Photo of Ray

Ray

  • 23 Posts
  • 2 Reply Likes
  • annoyed that I may have to spend more money on another weather station

Posted 2 years ago

  • 2
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Hello Ray,

We are currently investigating this issue.  Once we have an update that will be posted at the link below. Please let us know if you have any other questions.  Thank you and have a great day!

https://www.acurite.com/support/my-acurite-migration
Photo of Ray

Ray

  • 23 Posts
  • 2 Reply Likes
Still having issues with myacurite rain totals. I have now had a recording of 20mm of rain every day for the last 4 days when there has been no rain at all. I live in a drought affected area so accurate rain measures are vital especially when not home so I can make sure paddocks and stock are kept watered. I'm surprised this app is still being advertised as "A Window to your World" and an interface that provides peace of mind! Maybe less money on advertising and more spent on tech support and customer liaison. Please fix this problem or at least let everyone know what's being done to fix it.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Hello Gerry,

Thank you for this information.  This will help as we further investigate.  Thank you and have a great day!
Photo of Brian S

Brian S

  • 15 Posts
  • 1 Reply Like
I too am having the same problem using PC connect the rain total updates correctly but loses connection with your server whilst the other data continues to update.
Can you please notify me when you find a fix
Brian S
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Brian,

We are currently working on the rain issues on My AcuRite and will update the customers on the community forum once we have one. Thank you. Enjoy your day!
Photo of Stuart Brown

Stuart Brown

  • 1 Post
  • 0 Reply Likes
Do you know when a fix may be completed? My rain readings are accumulating at an alarming rate!
Photo of John Winn

John Winn

  • 3 Posts
  • 0 Reply Likes
This app is horrid..It now crashes constantly. I've given up on it. Trash..The old stuff worked better. I'm speaking of the windows app that is supposed to run on the windows PC that the system is connected to.
(Edited)
Photo of John Winn

John Winn

  • 3 Posts
  • 0 Reply Likes
I'm having the exact same issue. MyAccurite shows .07", but the display at home shows zero and it has not rained.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Hello John,

Thank you for reporting this issue.  We are still actively investigating this issue. Please let us know if you have any other questions.  Thank you and have a great day!
Photo of John Winn

John Winn

  • 3 Posts
  • 0 Reply Likes
New surprise for me. We had a huge downpour yesterday..My app still shows .07"..Didn't even register the rain, but it did register on the console. The old app worked so much better..At least it worked!
Photo of danwilks

danwilks

  • 13 Posts
  • 0 Reply Likes
I am having the same issue. MyAcurite continues the last daily rain total every subsequent day. I had 0.17 in of rain of 1/18 - which is the correct amount-  and MyAcurite is showing 0.17 in of rain both for yesterday (1/19) and so far for today (1/20) when there hasn't been rain either day. My display shows the correct amount.  

It is also reporting the 0.17 amount to wunderground so it might be an issue with the PC connect app. I had data reporting via rapid fire from PC connect directly to wunderground.

Thanks.
(Edited)
Photo of Norris Mealer

Norris Mealer

  • 1 Post
  • 0 Reply Likes
I had the same problem this morning Dan, only worse. Yesterday's rain here in the FL panhandle measured .63 inches in my "analog" rain gauge. It registered .80 on my 5 in 1 pro weather station. That's 21% too high and this kind of "over reading" has been consistent since I installed the unit just before Christmas. The unit is installed on a 20' pole clear of any obstructions so there is no placement issue here. I know I can reduce the reading by 8% with a half turn each on the calibration screws on the bottom of the sensor unit but that would still leave me with a significantly inaccurate (high) rainfall measurement. To top things off, my .80 total from yesterday cleared from my display after midnight but was registered on the app as a .80 rainfall event at 12:05AM . The rain had stopped at 11:09PM so the .80 of "phantom" rain is added to today's total corrupting the data. I know that we didn't pay thousands of dollars for NOAA certified equipment but when you advertise that your rain gauge tolerance is +-5% you shouldn't be shipping out gear that is >20% off.
Photo of danwilks

danwilks

  • 13 Posts
  • 0 Reply Likes
I unplugged the display from my computer and restarted PC Connect. That reset the rain count on both myacurite and wunderground back to 0. I'm guessing there is still a bug somewhere and this is just a temporary fix. I don't think we are going to get more rain until Sunday/Monday so I will check to see what happens after that. 

Norris, are you using a smarthub or PC connect? 

I am eventually going to get a smarthub so hopefully the software on that doesn't have the same issue, but for now I'll keep an eye on PC Connect.
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello All,

Wednesday, January 25, 2016

Many customers have noticed an issue regarding how rainfall is calculated and sometimes sporadically resets to zero during the day on both the charts and the day’s total accumulation. With the significant storm activity across the southeast this past weekend, we recognized the increased activity in our forums related to the rain reset issue and how it is impacting the accuracy of reported daily rainfall to My AcuRite and Weather Underground. One of the primary causes of the rain resetting you have experienced actually relates to a time-sync discrepancy between the smartHUB and the My AcuRite service; especially as the hour changes throughout the day (which is why you will notice the reset issue generally happens at the top of a new hour, i.e. 2PM, 3PM, 4PM, etc.). Because the smartHUB communicates directly to Weather Underground after communicating with the My AcuRite servers, when the smartHUB resets the rain total, it sends the reset data to WU as well. The development team is actively working on a fix to properly sync the time, which will prevent improper rain resets related to this issue.

What’s Happening
To explain the cause first requires explaining how the smartHUB handles rain data from the 5-in-1 Sensor and the standalone Rain Gauge. The smartHUB is responsible for tracking the rain total throughout the day, keeping this running total in its memory. Throughout the day, the smartHUB transmits this number online at normal intervals to My AcuRite and Weather Underground. At the start of a new day, the smartHUB wipes this memory, and restarts this daily accumulation of rain number at zero.

However, the smartHUB does not have an internal clock. As part of the process to track when a new day begins, the smartHUB receives an updated time of day when it checks in with the online servers in preparation to transmit sensor data. By comparing to the previously received time, the smartHUB can recognize when it has passed into a new day. For example, if its last received time was 11:59 PM, and the next is 12:00 AM, it knows it has passed into a new day, and will reset the accumulated rain data.

What is interfering with this expected process is the slight differences in time between servers, much like how different clocks in the home may be a minute or two apart. For example, if one server has a time of 2:00 PM, the smartHUB will update to this time. However, if on the next transmission it checks in with a server that has a time of 1:59 PM, instead of going back in time, it instead assumes it has entered a new day. Because the smartHUB believes it’s a new day, it resets the daily accumulation of rain back to zero, and transmits this new number online. This is when your online data improperly resets to zero on your graphs.

What We’re Doing About It
While we have made improvements to synchronize the time across the servers, we are also currently testing a fix to streamline time synchronization between My AcuRite and the smartHUB in such a way that the improper rain reset conditions never occur. This will restore accurate rain data being sent to both My AcuRite and Weather Underground.

We are sorry for the inconvenience, and appreciate your ongoing patience. We will be actively updating on this issue as more information becomes available.


https://www.acurite.com/support/my-acurite-migration
Photo of Shane Piantek

Shane Piantek

  • 3 Posts
  • 0 Reply Likes
my model 01092DIA is recording rainfall when neither my sensor or display unit is showing any rain at all it was to cold for rain and was sunny all day
Photo of Shane Piantek

Shane Piantek

  • 3 Posts
  • 0 Reply Likes
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6411 Posts
  • 200 Reply Likes
Hello Shane,

Are you using the smartHUB or are you connecting your PC Connect display into your computer? If you are using a smartHUB, what is the model number on the smartHUB?  Thank you.
Photo of Shane Piantek

Shane Piantek

  • 3 Posts
  • 0 Reply Likes
driect from screen to computer
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Shane,

We have emailed you at the address on file. Please check your inbox.