1512 Display missing segments

  • 1
  • Problem
  • Updated 1 year ago
I too am experiencing display segments not showing up.

I have tried the suggestions given in past posts but to no avail.

It is interesting that by slightly squeezing on the right side of the black frame those digits will appear again.

My 'QC' code on the backside of the battery compartment door is: 3916

Other than this I am happy with the way it has been working!

Thanks for your help!



Photo of Eric

Eric

  • 2 Posts
  • 0 Reply Likes

Posted 1 year ago

  • 1
Photo of AcuRite Tori

AcuRite Tori

  • 1368 Posts
  • 50 Reply Likes
Hello Eric,

I apologize but I am not sure what thread you are referring to so I am not sure what troubleshooting has already been performed. Please verify you are using a high quality alkaline battery. Reset the display by unplugging the displays AC adapter, removing batteries. and pressing the reset button located in the battery compartment for 10 seconds. After you have pressed the reset button for 10 seconds power up the display by reinstalling the batteries as well as plugging the AC adapter back in and pressing the reset button once more for 10 seconds. If this does not correct your issue please let us know. Thank you.
Photo of Eric

Eric

  • 2 Posts
  • 0 Reply Likes
Sorry for not making that clear, I did unplug the power and remove batteries, reset, new batteries and plug power, and with final reset. So just to be sure I did this again, still the missing segments in the 'Rainfall' section. I included another snapshot of this last attempt and nothing has changed. Thanks again for your help!


Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Eric,

We have emailed you at the address on file for more personal information and to initiate a warranty claim. Please check your inbox.