06022rm ticker display just reads gibberish worked good for 12 days anybody know what to do?.

  • 1
  • Problem
  • Updated 2 years ago
Ticker display started displaying gibberish after 12 days. anybody have a fix for this? Thanks, bj
Photo of BILLY J PACE

BILLY J PACE

  • 2 Posts
  • 0 Reply Likes
  • letdown

Posted 2 years ago

  • 1
Photo of AcuRite Crystal

AcuRite Crystal

  • 2000 Posts
  • 111 Reply Likes
Hi Billy,

The following instructions should help resolve any issues you are having with your display.

To do a factory reset: (THIS WILL CLEAR ALL OF YOUR HISTORY AND YOUR SETTINGS)

Please verify that you are using a name brand (Rayovac or Energizer) standard alkaline batteries in the display unit. We do
not recommend using anything that is heavy duty, rechargeable, store brand or Lithium inside of the display.

- Remove all power, AC adapter and batteries, from the display unit.
- Press and hold down the pin hole reset button, located in the battery compartment, for 20 seconds.
- Plug back into AC power and insert recommended batteries.
- Press and hold down the pin hole reset button for an additional 20 seconds.
- Verify that the unit has powered on and once connection has been made, attempt to set the time and date.

If this does not resolve the problem, please call AcuRite Customer Support at 877-221-1252.  Have a great day!
Photo of GertyPyne

GertyPyne

  • 1 Post
  • 0 Reply Likes
Thanks for sharing this useful information here.
I want to know the specifications for the Energizer.
What are the values for its Input and output?
Also what type of batteries i should use with it?
Photo of Harold Ashe

Harold Ashe, Champion

  • 1449 Posts
  • 312 Reply Likes
For the display, use ordinary alkaline AA batteries (Energizer, Duracell...any good "name brand").  You can use the same type for the sensor unless you are in a really, really cold climate in which case you might want to use lithium batteries.  I use Energizer Maximum, but do not use the Energizer Ultimate lithiums.