06016 display keeps resstting to default date and time

  • 1
  • Question
  • Updated 1 year ago
I recently purchased the 5 in 1 sensor 06016 and 06004. The display 06016 keeps resetting date and time. Even have trouble setting date and time because it resets before completed. Called customer service sent a new power supply. Still have the same problem.
Photo of Mike Kroll

Mike Kroll

  • 1 Post
  • 0 Reply Likes
  • disappointed

Posted 1 year ago

  • 1
Photo of Fred Flinstone

Fred Flinstone

  • 281 Posts
  • 40 Reply Likes
Sounds like it is a chip problem.  Try removing the power source.  Then all batteries.  Wait a minute and put in batteries ONLY and try setting it up and see what happens.  If still won't set, then send it back for repair. 
Photo of AcuRite Jennifer

AcuRite Jennifer

  • 11801 Posts
  • 536 Reply Likes
Hello Mike,

Please try a factory reset on your display.



To do a factoryreset: (THIS WILL CLEAR ALL OF YOUR HISTORY AND YOUR SETTINGS)

Please verify that you are using a name brand (Rayovac or Energizer) standardalkaline batteries in the display unit. We do not recommend using anything thatis heavy duty, rechargeable, store brand or Lithium inside of the display.

- Remove all power, AC adapter and batteries, from the display unit.
- Press and hold down the pin hole reset button, located in the batterycompartment, for 20 seconds.
- Plug back into AC power and insert recommended batteries.
- Press and hold down the pin hole reset button for an additional 20seconds.
- Verify that the unit has powered on and once connection has been made,attempt to set time and date.