00503W Outside temp maxed out at 158F

  • 1
  • Problem
  • Updated 4 months ago
I purchased the unit 4-5 days ago and have ever gotten anything but 158F for the outside temperature. I did a hard reset and nothing changed. Batteries are fresh Rayovac alkaline out of a package purchased last month and dated 11/26 for both AA and AAA. The barometric pressure and everything else is working except the outside temp which has stayed at the max of 158 no matter how many times I reset the system.
Photo of Kevin B

Kevin B

  • 2 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6236 Posts
  • 198 Reply Likes
Hello Kevin,
Do you have any other AcuRite products in your location?  I understand you have done troubleshooting steps already, we just need to make sure all troubleshooting has been exhausted. Rayovac Alkaline batteries are good batteries to use as long as they do not say High Energy. Please try the troubleshooting steps in order below. If this does not correct the issue, the sensor would need to be replaced. The product does have a one year warranty that we are happy to assist you with. Thank you.



Hard reset:



- Bring both units side by side and remove all batteries



- Place batteries into the outdoor sensor first



- Place batteries into display



- Allow units to sit side by side until they connect.



Photo of Kevin B

Kevin B

  • 2 Posts
  • 0 Reply Likes
This is my only AcuRite product. The batteries are standard Rayovac. I've done the hard reset according to your instructions 5 days ago. The sensor seems to be connecting because the barometric pressure is changing; however, the outside temperature continues to show it's max value.
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6236 Posts
  • 198 Reply Likes
Hello Kevin,
We have emailed you at the email address associated with your community forum account. Please check your inbox. Thank you.