00503W base stopped connecting with sensor

  • 1
  • Problem
  • Updated 2 months ago
Received as gift early December 2017. Worked well for 2 months, then base lost connection with sensor. I have removed the batteries and power supply. Then installed new batteries in sensor and saw the long flash red light followed by short flashes every 30 to 40 seconds. Then connected power supply to base unit. Actually established a connection the first try, waited 15 minutes, moved sensor 20 feet away and lost wireless connection. Repeated the process several times but never connected again. Sensor continues to flash, but that's all. Help, please?
Photo of David M Stephens

David M Stephens

  • 1 Post
  • 0 Reply Likes

Posted 3 months ago

  • 1
Photo of AcuRite Rachell

AcuRite Rachell, Employee

  • 6180 Posts
  • 196 Reply Likes
Hello David,
I understand you have done troubleshooting steps already however, we do need to make sure all troubleshooting steps have been exhausted. Please verify you are using the battery recommendations and try the troubleshooting steps listed below. If this does not correct the issue, the outdoor sensor will need to be replaced. Thank you.

Batteries:

•Verify you are using fresh alkaline batteries or lithium batteries (when temperature is below -4°F/-20°C) in sensor.

•Quality brand batteries are recommended, including Duracell, Rayovac, Energizer, or Kirkland.

•Verify batteries are fresh. The battery expiration date should be at least 6 years out. Batteries can lose 3% power or more every year in storage.

•Heavy duty, extra strength or generic / store brand batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the way these types of batteries disperse power. Each battery should not exceed 1.6 volts.

•Rechargeable batteries are not recommended for use with AcuRite products because they may cause performance irregularities due to the voltage instability of these types of batteries.

•Mixing different battery types (brands, old/new, etc.) is not recommended.

Hard reset:
- Bring both units side by side and remove all batteries
- Place batteries into the outdoor sensor first
- Place batteries into display
- Allow units to sit side by side until they connect.