Conversations

Conversations 1 - 20 of 272
Photo of Larry
AcuRite smartHUB End of Service
As our valued customers – we’d like to share an important product update with you. You may or may not be aware that we built a new con...
  • 4 me toos
  • 230 replies
  • Announcement
Photo of James Murray
do I disconnect the smart hub before connecting access?
I bought the access and need to know if I disconnect the old smart hub before powering up the new access?
  • 1 me too
  • 2 replies
  • Question
Photo of JohnH
MyAcuRite website and phone app not updating, but WU has current data? (Using Access hub)
I upgraded from the SmartHub to the Access hub earlier and have had a flawless experience, until last night at 11 pm. It seems my interne...
  • 2 me toos
  • 8 replies
  • Problem
Photo of AcuRite
AcuRite Access Orders
Due to the overwhelming response of the release of the AcuRite Access, we are currently experiencing a slight delay with the orders proc...
  • 2 me toos
  • 40 replies
  • Announcement
Photo of Joseph Pujia
How do I keep the back light on all the time?
I want the back light to stay on all the time. How do I set it to stay on all the time.
  • 1 me too
  • 5 replies
  • Question
Photo of Skier76
Access Connection Issues
Hi everyone, I received two Access units this week in the mail. I'm running two 5 in 1 stations at different locations.  I have setup th...
  • 5 me toos
  • 35 replies
  • Problem
Photo of Ron Gurnsey
09150TRX AcuRite Acu-Link Internet Bridge isn't working anymore.
I can't connect to my 09150TRX AcuRite Acu-Link Internet Bridge. It doesn't have any network port link lights, and the blue flashing ligh...
  • 4 me toos
  • 24 replies
  • Problem
Photo of Chris Locker
Acurite access losing sensor connection after network outage
New Acurite Access loses sensor connections after network outage. My location is connected by a WISP and occasionally sees network outage...
  • 1 me too
  • 1 reply
  • Problem
Photo of Dick Stetson
I got an email for a special on a station @ $119.95. When I got to the cart it was $169.95 Dissapointed
Sales E-mails
  • 1 me too
  • 4 replies
  • Question
Photo of Brenda Larsson
Mac address is invalid Device must be connected and reporting data to claim it. Please make sure the device is connected to your router and
Mac address is invalid Device must be connected and reporting data to claim it. Please make sure the device is connected to your router a...
  • 1 me too
  • 2 replies
  • Problem
Photo of Andrew
Had my first power outage with the new Access
And things didn’t go well , So power went out around noon but for only 5-10 sec. Then 2 hrs later I get a message saying Loss of Communic...
  • 2 me toos
  • 9 replies
  • Problem
Photo of Michael Lawrie
Acurite 02064M - Sensor batteries
I have had nothing but problems with this 02064M since the day I got it. I am on my third base unit, the previous two both had faulty LCD...
  • 1 me too
  • 11 replies
  • Problem
Photo of caredlands
Altas Elite
What features are you looking for in this new weather station ----  Ideas ???
  • 1 me too
  • 28 replies
  • Idea
Photo of Bryan Dudones
Inaccurate Wind Speed
First, I love the 5 -in-1 Pro Weather Station and hub since I purchased about 2 months ago. Overall, I find the readings to be very accur...
  • 2 me toos
  • 11 replies
  • Problem
Photo of Graham Drinkwater
Not Reporting to Weather Underground
I have the new bridge and it works fine locally. However, I have never been able to upload weather information to WU. I have followed eve...
  • 10 me toos
  • 29 replies
  • Problem
Photo of Nat Gross
Android API for developers?
[As an Android developer,] Can I access the hub via Android Intents, or a published API? I would like to get the data directly into my ow...
  • 2 me toos
  • 8 replies
  • Question
Photo of Carl Camp
5in1 Pro Sensor, bearing lubrication for the Anemometer?
I've been using a 5in1 Pro Sensor for a little over a year.  The unit has worked well, until a few weeks ago when I realized the Anamomet...
  • 3 me toos
  • 6 replies
  • Question
Photo of mike schowalter
02027A1 - No backlight
No backlight unless button is pressed and then it only stays on 4 seconds.
  • 1 me too
  • 9 replies
  • Problem
Photo of Kevin W
12 volt adapter
I live on a boat and would like to power my HD weather station with ship's power instead of having to use the AC adapter. Do you guys sel...
  • 1 me too
  • 6 replies
  • Question
Photo of NJS
09150 smartHUB obsolete?
Just received my 09150 smartHUB as a Christmas gift and just read a post suggesting the SmartHUB is obsolete. 1. Anyone know if this ...
  • 1 me too
  • 3 replies
  • Question