Conversations

Conversations 1 - 20 of 1655
Photo of Go Bananas
How best to check and calibrate sensors?
How best to check and calibrate sensors? What is the best way to check and insure accuracy of any and all Acu-Rite sensors? Thanks
  • 2 me toos
  • 11 replies
  • Question
Photo of Harold Buchanan
losing contact
Can you send me the email that solves the problem of the 5 in 1 losing contact with the server:My AcuRite has not received a signal from ...
  • 1 me too
  • 2 replies
  • Question
Photo of Kevin Bensen
Adjusted Pressure in MyAcuRite Sent To Weather Underground?
Hello, I recently converted to MyAcuRite and noticed that I can adjust the pressure. Unfortunately the adjusted pressure is not being sen...
  • 1 me too
  • 8 replies
  • Question
Photo of David Porter
Acurite 01074M Weather Station Measuring 99% Humidity
I have an Acurite 5 in 1 01074M Weather station with a 06014RM sensor that I purchased on 9/22/2017. We recently had a big rain storm a f...
  • 1 me too
  • 13 replies
  • Problem
Photo of AcuRite
AcuRite Access Firmware Version 47 Release
Last night we rolled out a firmware update for AcuRite Access, which will automatically be applied to any connected devices over the nex...
  • 4 me toos
  • 26 replies
  • Announcement
Photo of J
Model 75107TBLA1 - Today is Wednesday and the clock shows Monday.
Model 75107TBLA1 - Today is Wednesday and the clock shows Monday. Nothing that I have done will allow me to reset that. It jus loops over...
  • 1 me too
  • 4 replies
  • Problem
Photo of Terry
Model 00621W2
These should be called En-Acu-rite,Sometimes maybe acu-rite,if your lucky might be close to acu-rite.  I put mine in learning mode about ...
  • 1 me too
  • 3 replies
  • Problem
Photo of David U.
Faulty Readings on AcuRite 5 in 1 Weather Station
I have the AcuRite 5 in one station - delived just two days ago. It showed .25 on the rain scale, in spite of no rain. I did the reset,...
  • 1 me too
  • 3 replies
  • Question
Photo of Graham Drinkwater
Not Reporting to Weather Underground
I have the new bridge and it works fine locally. However, I have never been able to upload weather information to WU. I have followed eve...
  • 10 me toos
  • 32 replies
  • Problem
Photo of Jacobs Labs
Vintage Acurite thermometer broke!
I had one of the vintage John L Chaney Acurite meat themometers from the 70s or 80s, but it brok in a sink full of dishes. It had red flu...
  • 1 me too
  • 1 reply
  • Question
Photo of KR
monitor Refrigerator/Freezer temps remotely with the AcuLink bridge
I would like to see the temperature of the Refrigerator/Freezer sensors with the 00986 display and would also like to monitor the temps r...
  • 2 me toos
  • 4 replies
  • Idea
Photo of Tom Lay
Acurite Access, Meteobridge and Rachio Smart Irrigation Control
Here is a typical solution that many Rachio and Acurite customers have developed.  The problem is that Rachio utilizes local weather info...
  • 1 me too
  • 2 replies
  • Problem
Photo of Murray Stafford
battery life
Is anyone else having issues with battery life? My five and one sensor is to the point where I am replacing the batteries every 4 weeks. ...
  • 4 me toos
  • 22 replies
  • Question
Photo of Tom Ritchie
Atlas Elite weather station availability
When will this new weather station be available to purchase?
  • 2 me toos
  • 14 replies
  • Question
Photo of Catina Mount
My son broke a Galileo thermometer I washed the towels in my machine and am concerned about using the dryer - they smell like lighter fluid
My son broke a Galileo thermometer. I washed the towels in my washing machine that I used for cleanup. I am concerned about putting them ...
  • 2 me toos
  • 2 replies
  • Problem
Photo of bergmanndw
New SmartHub
Connection issues
  • 1 me too
  • 3 replies
  • Problem
Photo of sky
Dashboard with AcuRite Access is brain dead!
I previously owned a AcuRite smart Hub and rarely had a problem with it.  However, my frustration level with the 'new and improved' AcuRi...
  • 1 me too
  • 3 replies
  • Problem
Photo of King George
I am getting the error message "This device is already in use."
I purchased an Acurite Access from amazon.com and tried to register it today. I am getting the error message "This device is already in u...
  • 1 me too
  • 3 replies
  • Problem
Photo of Gary G
records rain when there is no rain
I have had my 5 in 1 pro for a few years now and has worked flawlessly. That is until recently, I live in the desert SW and we haven't ha...
  • 8 me toos
  • 28 replies
  • Question
Photo of Dan Foote
New Access not connecting....
Getting the same error message as others..... "Device must be connected...." I have tried to call Tech Support several times over the las...
  • 1 me too
  • 1 reply
  • Problem