1602bpdi large

01602 Professional Weather Center with Easy Mount 5-in-1 Sensor

Conversations

Recent Conversations
Conversations 1 - 15 of 111
Photo of Michael Lorence
How To Keep Insects Out
Overthe past three weeks I've had to take down my 5-in-1 weather station from a 10' mounting pole to three times to remove a mud dauber ...
  • 1 me too
  • 3 replies
  • Idea
Photo of Mike Ulrich
I appear to be getting false alerts!
At lest one or more times each day I am getting alerts that my signals from my 5 in 1 station and 3 remotes have not been connected for a...
  • 2 me toos
  • 4 replies
  • Problem
Photo of Bill Nivison
Rain gauge doesn't appear to be working on my new installation
I have a new 5 in 1 weather station and it's been raining steadily since I installed it and I've registered nothing on my display. I chec...
  • 1 me too
  • 1 reply
  • Problem
Photo of Aspedestic
01602BPDIA3 (Bass Pro labeled) Display dosen't disply rainfall...new month began...rainfall display resumes!*#!!
5 in one system w/ interior display. Interior display was not recording rainfall. Outdoor sensor checked and cleared of any obstcles. P...
  • 1 me too
  • 1 reply
  • Question
Photo of Peter Metz
Signal Strength Poor/Status Offline/Battery Normal
I have a 5-in-1 Weather Station Pro that is about 3 months old. I also have an Acurite Access and three Acurite temperature and humidity ...
  • 1 me too
  • 0 replies
  • Problem
Photo of Amartya Ghosh
Do you have any distributor in India?
  • 1 me too
  • 0 replies
  • Question
Photo of Roy Griffith
Access, 5 in1, Range extender, 620 feet?
I have a cottage that sits 620 feet from a boat dock. In the cottage I have an Access and on the roof a 5 in 1. If I bought another 5 in ...
  • 1 me too
  • 4 replies
  • Question
Photo of Steve Lipp
Sharing data with other services
Are there any plans to interface PC Connect to share data with other services? The weather underground has to be the most neglected websi...
  • 1 me too
  • 2 replies
  • Question
Photo of john d
Acurite 33 degrees temp reading through bridge
My acurite 5 in 1 works great when you get the info off the display. BUT when I go online or through the app I get wacky readings. Thi...
  • 1 me too
  • 0 replies
  • Question
Photo of Rick
Unfortunate obsolescence
So I bought my 5-1 and smart hub two years ago. After two years, the 5-1 started eating batteries (less than two weeks) and I found th...
  • 2 me toos
  • 4 replies
  • Problem
Photo of LeeBo337
Accuracy and Height: Wind, Temp, Humidity, and Rain
I have a 5 and 1 and recently read a publication from the feds on Citizen’s Observation Weather Program. They recommend heights of 33’ ...
  • 1 me too
  • 2 replies
  • Question
Photo of Freddie
MyAcuRite dashboard not connecting with AcuRite Access but weather is being shared on Weather Underground?
My AcuRite Access has a solid blue light on the front as well as a blinking green light/solid amber light at the Ethernet port but yet My...
  • 4 me toos
  • 4 replies
  • Problem
Photo of J. Alan Hughes
Incorrect data going to Weather Underground (Precip Rate specifically)
Just noticed this problem today.  My weather station is reporting a precipitation rate of 9.99 in/hr for some reason while on the My AcuR...
  • 1 me too
  • 1 reply
  • Problem
Photo of Pat Goodyear
my anemometer has stopped transmitting accurate wind speed, never goes above 2mph
my anemometer has stopped transmitting accurate wind speed, never goes above 2mph, battery good, I have tried resetting the unit.   Any o...
  • 1 me too
  • 3 replies
  • Problem
Photo of Ron Thompson
5-in-1 sensor battery life, AGAIN!
Hello All, This seems to be a recuring problem, if this was a car it would probably be something that would be triggering a recall for a...
  • 1 me too
  • 7 replies
  • Problem