Joining the Community is Easy!

Our community is a great place to share and connect with other people that are passionate about the same things you are. Get your questions answered, share your ideas and feedback, get your problems solved, and give back by helping others! It only takes a minute to get started.

Get Started Today

  • Step 1: Sign Up
  • Step 2: Follow Categories

Conversations

Recent Conversations
Conversations 1 - 20 of 10300
Photo of Jaron Barrett
Unit is not registering wind speed.
My unit is showing a wind direction but showing 0 mph even though the wind dial is spinning outside. I have reset the system and made sur...
  • 4 me toos
  • 6 replies
  • Problem
Photo of Duane Tiemann
Access hub (sort of) dies periodically
I have 2 Access hubs and 1 SmartHub. My first Access hub went all red in the browser (all thermometers unavailable - i.e. red) again toda...
  • 1 me too
  • 0 replies
  • Problem
Photo of joan hanlon
Need weather station to take camping - no AC connection
I would like to know if you have a Weather Statio product that runs ONLY on batteries?  Would like to take a weather station camping, but...
  • 1 me too
  • 2 replies
  • Question
Photo of John
New Access drops internet connection randomly and will only re-connect after power cycling
Installed new Access to replace smartHub. Connected without a problem. All sensors and MyAcuRite work fine. But once or twice a day the l...
  • 1 me too
  • 1 reply
  • Problem
Photo of Jillian A. Bogater
OMG when will you pick up??
I literally have been on hold for three hours, and time is ticking away toward the day's close. I ordered an Access several months ago an...
  • 1 me too
  • 3 replies
  • Problem
Photo of Gilchrist Family
PC Connect no longer detecting device
Status of PC Connect shows Indoor display: Not detected Device worked fine up until about 4 weeks ago Have tried 3 different USB cables...
  • 1 me too
  • 1 reply
  • Problem
Photo of AcuRite
AcuRite Access Firmware Version 47 Release
Last night we rolled out a firmware update for AcuRite Access, which will automatically be applied to any connected devices over the nex...
  • 2 me toos
  • 15 replies
  • Announcement
Photo of Skier76
Access Connection Issues
Hi everyone, I received two Access units this week in the mail. I'm running two 5 in 1 stations at different locations.  I have setup th...
  • 8 me toos
  • 91 replies
  • Problem
Photo of Hank Cook
Just received my 5 in 1 weather station and while trying to connect to the computer. It asks for the device ID. Where do i find that # t
Can't find my Device ID. 06
  • 1 me too
  • 1 reply
  • Problem
Photo of rvdriver2014
Model 01055 temperature reading
Outside Temp reads 124 degrees F.  System is 01055.  Operation was fine for the first month, or so (within reason)  All other indications...
  • 1 me too
  • 3 replies
  • Problem
Photo of Jean roemer
5 in 1 station quit reporting rainfall; put in new batteries and still doesn't work. Any help/suggestions? Thanks.
Rainfall doesn't show.
  • 1 me too
  • 4 replies
  • Problem
Photo of Brent Lefcheck
Acurite atlas
Noticed today on amazon the atlas is on there for sale again but says it’s not in stock(well obviously since acurite hasn’t released the ...
  • 1 me too
  • 13 replies
  • Question
Photo of stanritchie
Appears that history data is missing.
It appears that history data is missing.  The website and iPhone app both show "No charts available for the selected date range.".  If I ...
  • 1 me too
  • 0 replies
  • Problem
Photo of John Beattie
Myaccurite servers down?
Myaccurite desktop and phone app has been offline for the last 2-3 hours, but has been transmitting data flawlessly to weather undergroun...
  • 1 me too
  • 0 replies
  • Problem
Photo of Mark
Chart data download does not show indoor temperature
I purchased & installed the new Access model 09155M earlier this month, mostly because I was experiencing frequent lost connections when ...
  • 1 me too
  • 1 reply
  • Question
Photo of John Haas
Response
Tried to call today. Kept getting that I was number 2 in wait list. Then 1. After over 45 minutes waiting I used the option to have someo...
  • 1 me too
  • 3 replies
  • Question
Photo of Bradley Madden
No charts available for the selected date range
Acurite smart hub is sending data to my CPU.  It says "No charts available for the selected date range."
  • 1 me too
  • 0 replies
  • Problem
Photo of Lucas Allan Bourque
5 IN 1 Humidity reading is malfunctioning and temperature problems
Lately my 5 IN 1 PWS has been reporting to humidity of 99% when it has been quite dry and while it is raining or the humidity is high it ...
  • 2 me toos
  • 9 replies
  • Problem
Photo of Robert Brand
Problem SmartHub to Access
Trying to move from SmartHub to Access and not getting it to work.  Blue Network status light is on solid.  But on back amber light is ...
  • 1 me too
  • 7 replies
  • Problem
Photo of tomg8888
Outdoor and indoor humidity way off
I put the outdoor sensor next to the indoor receiver on my new 00411 temp/humidity unit. Thinking they should read the same.. but the out...
  • 1 me too
  • 3 replies
  • Problem